Subject: Re: AlphaPC 164SX AlphaBIOS to SRM conversion
To: Joey Knight <>
From: Tom Knienieder <>
List: port-alpha
Date: 10/02/1999 00:00:38
Joey Knight wrote:
> Hi,
> Can anyone offer advice/experience with the following situation?  I'm been
> suffering through this dilemma for some time, and I've run out of ideas . .
> . Thanks!
> >>>I am trying desperately to convert an AlphaPC 164SX motherboard from
> >>>AlphaBIOS to SRM, but to no avail.  The AlphaPC 164SX only has room for one
> >>>console image, and I need it to be SRM.  I have tried EVERYTHING to convert
> >>>the image, but nothing seems to work.  I have tried:
> >>>
> >>>1)  Downloading the Alpha Firmware v5.5 SRM image from Digital's
> firmware website, >>>following
> >>>the instructions in the release notes to upgrade via the
> >>>"Upgrade AlphaBIOS . . ." selection.  Upon hitting the enter key at this
> point >>>(with the downloaded "fwupdate.exe" in the floppy drive), the
> system accesses the >>>floppy for some
> >>>time, and then just hangs . . .
> >>>
> >>>2)  Obtaining the SRM image straight from v5.4 and v5.1 CDs to a floppy in
> >>>case the v5.5 image was corrupted in the transfer, or in case the v5.5
> >>>"fwupdate.exe" was corrupted off the website.  The system still hangs
> via the strategy mentioned above . . .
> >>>
> >>>3)  Upgrading to the latest AlphaBIOS version (v5.66), which worked just
> >>>fine, and then trying to upgrade to SRM via the strategy mentioned
> above.  Nope.
> >>>
> >>>4)  Booting the motherboard in "Fail-safe" mode and accessing the LFU in
> >>>this manner.  Unfortunately, it doesn't offer me the choice of upgrading to
> >>>SRM, it just mentions that the AlphaBIOS image can't be found once I type
> >>in
> >>>"update" at the "UPD>" prompt.  I attempted to get around this by
> downloading "sx164_v5_5.sys" from the web and using "update fw -path
> dva0:sx164_v5_5.sys" . . The LFU reads the floppy for about 30 seconds and
> then mentions that the image is "bad".  I tried downloading the
> "sx164srm.rom" file from the AlphaPC 164 (not 164SX) firmware spot, and
> tried pointing LFU to this file, still "bad image".  Of course, this latter
> strategy might not work anyway since this wasn't the 164SX rom image per
> sae, but rather the 164 image, but I'm trying anything at this point . . .
> >>>
> >>>Any direction would be MUCH appreciated,
> >>>
> >>>Joey
> 972-664-7731

1.) prepare 2 floppy disks.
    format them on a DOS-PC (normal FAT)

2.) go to


3.) put fwupdate.exe on the first DOS Floppy
    put sx164_v5_4.sys on the second DOS Floppy

4.) power off the alpha and open the case of your alpha

5.) set the "last" jumper to the "other" position.
    (the docu calls the jumper emergency something ....)

6.) put disk1 with fwupdate.exe in the floppy, 
    start the alpha

7.) insert disk2 with the sx164_v5_4.sys file when
    the system asks for additional disks

8.) in the UPD >> 
    do a:
    update fw -path fw_srm
    (this loads the srm firmware)

9.) ignore messages about not having found fw_nt.
    (at least my box has not enough onboard ram to hold
    alphabios and srm at the same time)

10.) exit the UPD, power off the machine. bring back
    the jumper on the motherboard in it's old position.

11.) reboot - your should be in the srm console now.

PS: no warranty at all, this is what i did on my box.