Subject: 164SX hangs on boot?
To: '' <>
From: Tom Haapanen <>
List: port-alpha
Date: 09/19/1999 15:06:53
I have a previously succeeded in installing NetBSD 1.3.2 on a AlphaStation
4/233, and have been happy with the experience.  Now, however, I need some
more power for a web server, so I am attempting to build a new box.

Here is the configuration

164SX at 533 MHz
SRM version 5.5
Matshushita IDE CD-ROM
SMC 8432 (aka 21041 AA) PCI
ATI Mach32 PCI

I succeeded in getting the system to run the latest SRM (ugh ... this is
STILL a most baffling and frustrating experience), and got the existing
NetBSD box to service the bootp requests.  It then picks up the
boot.netbsd.alpha file by tftp from a BSDI box, and netbsd.gz by NFS from
the same BSDI box.

The initial boot process starts fine, but, alas, doesn't complete.  Here are
the last lines displayed on the screen (retyped by hand):

ciao0 at mainbus0: ID0 (primary), PCA56 (unknown minor type 2)
ciao0 at mainbus0: DECchip 2117x Core Logic Chipset (Pyxis), pass 1
ciao0: extended capabilities: 1<BWEN>
ciao0: using BWX for PCI config access

After that single "p" on the final line, the cursor creeps along to the end
of the line, and then goes to first column on the next line, and finally
stays there.  At this point, mountd on the BSDI box believes that the 164SX
is still connected.

I have tried this with 1.4 and 1.4.1 kernels, with no difference.  I have
tried with IDE drives connected or disconnected, with no difference.  And
finally, I have tried different boot flags, with no difference.  If you take
the IDE out of the picture, I really have a bare 164SX board with just 128
MB, Mach32 and a 21041, so this should not be a hardware compatibility

Where do I go from here?  How do I determine whether I have faulty hardware
(the 21041 and Mach32 were functional before, but board and memory are new)
or whether I have a configuration/installation problem?  Should I try this
with a serial console instead (I really don't need a graphic console)?

Thanks ...

Tom Haapanen