Subject: IPv6 no longer working on alpha? (or with vr driver?)
To: None <,>
From: Dave Huang <>
List: port-alpha
Date: 08/09/1999 14:15:55
I've got a D-Link something ethernet card in my Alpha PC164:
  vr0 at pci0 dev 5 function 0: VIA VT3043 (Rhine) 10/100 Ethernet Ethernet
  vr0: interrupting at eb164 irq 2
  vr0: Ethernet address: 00:80:c8:f7:c6:96
  ukphy0 at vr0 phy 8: Generic IEEE 802.3u media interface
  ukphy0: OUI 0x006040, model 0x0000, rev. 0
  ukphy0: 10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto

(btw, what's with the "Ethernet Ethernet" on the first line? :) Until
recently, it had been working fine for everything, including IPv6.
However, a kernel compiled from last Friday's -current (Aug 6) gives me
an error when trying to setup the IPv6 stuff:

  vr0: supplying EUI64: 00:80:c8:ff:fe:f7:c6:96
  root on sd0a dumps on sd0b
  root file system type: ffs
  vr0: interface not running
  vr0: SIOCSIFADDR error 340088

and "netstat -i" doesn't show any IPv6 addresses for the interface.
Trying to add one with ifconfig gives me:
  ifconfig: SIOCAIFADDR: Unknown error: 340088
  vr0: interface not running

I'm not seeing this on an i386 with 3c595 (ep) ethernet, or a mac68k
with AMD MACE (mc) ethernet, so I'm guessing the problem is either
alpha-specific or vr-specific. Any thoughts? Error 340088 is unknown to
me too :)
Name: Dave Huang     |   Mammal, mammal / their names are called /
INet:   |   they raise a paw / the bat, the cat /
FurryMUCK: Dahan     |   dolphin and dog / koala bear and hog -- TMBG
Dahan: Hani G Y+C 23 Y++ L+++ W- C++ T++ A+ E+ S++ V++ F- Q+++ P+ B+ PA+ PL++