Subject: Installation experiences
To: None <>
From: Dave Huang <>
List: port-alpha
Date: 05/25/1999 07:39:20
Well, I'm the proud new owner of a AlphaPC 164 *bounce* :) It came with
ARC firmware, so I played around with NT for a bit... (btw, the Win2K
beta 3 installation is so slow and annoying :) I haven't bought all the
hardware I want for the system yet; I just stole parts from other
machines I have lying around, and ended up with a system that NT has
almost no drivers for :) I quickly got tired of 640x480 16 color VGA
with no network, so it was time for another OS.

My Linux-using friend was with me (he had gotten a board too and we were
testing if they were DOA), so we decided to try Redhat 6.0... couldn't
get it to work for some reason though; it'd boot the kernel, ask for the
floppy with the root filesystem, load a bit of it, then panic with a
"cannot mount root" sort of error. We fiddled with that for a bit, then
gave up :) Time to flash the SRM console and try NetBSD...

Changing the firmware went smoothly... after it rebooted, I got a
pleasantly blue screen. Hit return and got the >>> prompt, then
proceeded to boot NetBSD boot floppy number 1. It printed some stuff
saying it found a valid boot block, was loading the boot code, etc...
then it just sat there with the floppy clicking away. After a while, the
floppy stopped reading, but the disk activity light was still on.
Banging the keyboard didn't do anything, so I hit the reset button and
tried again, with the same results. Then I figured out that I had the
console set to the serial port instead of the video card, which is why I
had to hit a key to get the SRM prompt to show up :) After changing the
console setting, I booted the floppy again and got nice progress
messages and everything worked :) Anyways, perhaps it might be worth
mentioning in the docs to make sure the console is going to the right
place. Since I was talking to the SRM via the keyboard and VGA card, I
assumed that's where NetBSD would be sending its output too...

Didn't do anything fancy with sysinst, and it worked fine. I did notice
that the ftp progress bar looks bad in the small window. Instead of
staying on one line and updating itself with the new percentage done,
ETA, etc..., it wraps and generally makes a mess of the window.

Also, it didn't set rc_configured=YES for me... is it supposed to? (I
admit that I didn't read the INSTALL document too closely... once it
booted into NetBSD and started sysinst, I knew how to get things running
from there, and didn't bother reading the rest of INSTALL :)

Anyways, it's installed, and I've even got a NetBSD-current kernel
compiled and running on it... did get a crash though :( If I try to run
the DEC OSF 3.0 SETI@home client, I get:

vrele: bad ref count: type VSOCK, usecount -3, writecount -1, refcount

fatal kernel trap:

    trap entry = 0x4 (unaligned access fault)
    a0         = 0xdead0052deadbff7
    a1         = 0x29
    a2         = 0x1b
    pc         = 0xfffffc000036dbf8
    ra         = 0xfffffc000036dbcc
    curproc    = 0xfffffc0000d8f740
        pid = 192, comm = csh

panic: trap
Stopped in csh at Debugger+0x4:   ret    zero,(ra)

"trace" at the db> prompt doesn't give me anything.
The "vrele:" line changes each time... it looks like it's pretty random,

BTW, it's definitely not supposed to crash, but is it supposed to work?
I have "options COMPAT_OSF1" in my kernel config... will I need
libraries from an OSF1 system? Also, I notice that there are some files
for COMPAT_LINUX on alpha, but COMPAT_LINUX isn't documented as working
on alpha... is the documentation just out of date, or does it not work
yet? :) I tried compiling a kernel with COMPAT_LINUX, and got a compile
Name: Dave Huang     |   Mammal, mammal / their names are called /
INet:   |   they raise a paw / the bat, the cat /
FurryMUCK: Dahan     |   dolphin and dog / koala bear and hog -- TMBG
Dahan: Hani G Y+C 23 Y++ L+++ W- C++ T++ A+ E+ S++ V++ F- Q+++ P+ B+ PA+ PL++