Subject: SRM Console update (Round 2) - Please Help!
To: #List Alpha <>
From: Paul Goyette <>
List: port-alpha
Date: 05/18/1999 17:50:21
Well, I got the fwupdate.exe program to load.  Actually, it was loaded
all the time, but it didn't know how to deal with my video card (a
Matrox Millenium II).  But it works on the serial console.

Unfortunately, when I tell it to Update, all I get is a complaint that
it can't find fw_nt file.  Here's what I get from the fwupdate utility:

	UPD> verify

	fsb             Verifying 3.1...  PASSED.

	fw              open failure firmware filename 'nt_fw' 

	UPD> display
                        Digital AlphaPC 164LX 533 MHz

	SRM Console V5.4-1              OpenVMS PALcode V1.20-2, Digital  
		UNIX PALcode V1.22-2

	SROM Revision: 3.2
	Alpha 21164A-2
	Pyxis ASIC Pass 2


which looks to me like it thinks that SRM V5.4-1 is there.  But how can
I make it boot from it?  :)

I've tried using mkboot to build a bootable floppy with the fwupdate.exe
thing on it, but mkboot complains that the file is too small.  I've also
set the jumper to do a "failsafe" boot, and it successfully loads the
fwupdate.exe from the msdos floppy, but I get the same results when I
run it - complaints about nt_fw.  

I've tried all the other jumper settings (including the ones listed as
"Reserved" in the scant documentation that came with the system) in an
attempt to bypass the ARC code completely, but nothing works.  It just
always comes up in the ARC menu window.

Does anyone have any idea how I can proceed?

---------- Forwarded message ----------
Date: Tue, 18 May 1999 04:07:29 -0700 (PDT)
From: Paul Goyette <>
To: #List Alpha <>
Subject: Newbie - please help - Console update

OK, I'm not a NetBSD newbie, but I am an Alpha newbie, so please bear
with me a bit.

I just got my new AlphaPC 164 system, but unfortunately it came with
that _other_, non-BSD variant of Un*x installed.  So, I'm trying to get
NetBSD up on  it.

First thing I noticed is that it came with what appears to be ARC
console firmware (at start-up, if I press F2 for Set-Up, I get a window 
with title AlphaBIOS 5.66). So I went to the DEC web page and downloaded
the firmware upgrade, formatted a FAT floppy, and put the upgrade image
on the floppy, renamed appropriately to fwupdate.exe.

Then, I select the AlphaBIOS Upgrade... option from the menu and press
Enter.  It goes off and frobs the floppy for a bit, then it appears to
reload/reboot, displays some text about my video card and then "BIOS
Emulation V1.15a".

Then, it goes to a totally blank, blue screen with an underline cursor
in the upper left corner and just sits there.  No more floppy frobbing,
nothing.  I've waited at least ten minutes in this state, and nothing
seems to have any effect.

So, if any of you kind souls could shed a little light on what I'm doing
wrong (I'm certain it's pilot error!) I'd appreciate it.

Upgrade URL used:

| Paul Goyette      | PGP DSS Key fingerprint:   | E-mail addresses:     |
| Network Engineer  |   BCD7 5301 9513 58A6 0DBC |    |
| and kernel hacker |   91EB ADB1 A280 3B79 9221 | |