Subject: Re: UPDATE: Symbios 8750SP / IBM DDRS U2W boot problems
To: Jason Thorpe <>
From: Joerg Czeranski <>
List: port-alpha
Date: 05/17/1999 01:10:43
Jason wrote:
> On Mon, 17 May 1999 00:20:16 +0200 (MET DST) 
>  Joerg Czeranski <> wrote:
>  > > After adding "options SCSI_NCR_MAX_WIDE=0" to the kernel config file,
>  > > it detects and uses the DDRS without problems:
>  > rz0 at scsi0 target 0 lun 0 (LID=0) (IBM     DDRS-34560D      DC1B) (Wide16) 
> Okay...
> So, you're saying that NetBSD negotiated Wide on the disk, then failed because
> it was connected via a narrow cable.
> ...yet Digital UNIX _also_ negotiated Wide, yet can use it even though it's
> connected via a narrow cable?

No, I'm not sure I'm saying that. :-)

I don't know whether the "Wide16" means that the disk could support wide,
or that it's switched to wide.

> A couple of comments...
> In order to make the disk work properly, I had to do some frobbing... First
> of all, I needed to set the "single-ended mode" jumper on the disk; I'm
> assuming you've already done that, since it talks to the host _at all_.


> Second, I needed to get a wide->narrow adapter that did the right thing
> with the unused signal lines; namely, pull them (and only them) to an
> active terminator.  I think there's also a jumper that allows you to
> disable Wide negotiation.

The adapter had the unused lines open and the SRM console didn't recognize
the drive at all (though the same adapter worked with an UW DCAS and a
AXPpci33).  I read an article in the German magazine c't about it,
they advised to connect the additional 8 data lines and a ninth line
together and via one 4.7kOhm resistor to the termpower line.

I did that, and only then was the DDRS detected by the SRM console
and NetBSD.

> Perhaps if you do the latter, the disk will (perperly) refuse to negotiate
> Wide transfers.  In my case, obviously, the driver never tried.
> Now, it could be that Digital UNIX, when it detected a failed transfer
> in Wide mode, suppressed the error message, and fell back on Narrow.
> I don't know.  And Digital UNIX drivers are pretty awful reading :-)

Maybe, I've never seen Digital UNIX sources. ;-)

Unfortunately the DDRS documentation doesn't mention a jumper for wide.
Only for single ended and target initiated synchronous negotiation (which
is off) and other stuff like autostart.

The host adapter came without printed documentation - I haven't checked
the contents of the windows floppy - and it doesn't have any jumpers
at all.

> Just out of curiosity, is ths a Tekram DC-390 board?

No, the stuff on the board reads:
"SYM8750SP", "FCC ID: B8JSYM8750SP",

A sticker: "348-0036086A"
On the chip: "SYMBIOS LOGIC 53C985J 609-0392654 DP16007 9804N"

And I bought it as "original Symbios 8750".