Subject: -E2 TGA framebuffer
To: None <>
From: Jason Thorpe <>
List: port-alpha
Date: 08/18/1998 15:54:31
Well, it appears as if my -E2 framebuffer was DoA ... the SRM (even the
latest one) doesn't initialize it correctly, or something.  The screen
is filled w/ junk, and the text begins 1/2 across the screen, and is
not really readable.  The hardware cursor, however, appears in the correct
place!  So I'm not really sure what is going on, here..

The NetBSD kernel does NOT panic w/ my changes, so I think I am going to
check the rest of them in.  But the text is still not readable, really.
The raster code still doesn't grok the 24-bit framebuffer, so it will
need some more work, but this is a step in the right direction, a least.

I also see some purple/blue vertical lines spaced the width of the hardware
cursor, and the text, again, starts 1/2 across the screen once the kernel
starts... but at least the screen is cleared, so the junk is gone.  Scrolling
doesn't appear to quite work properly, either, but I suspect this is more
24-bit lossage.

I would really appreciate testing assistance, here, as I can obviously not
test this myself, very well.  The code should appear in tomorrow's SUP,
and I can make a GENERIC kernel if you really need it.

Jason R. Thorpe                             
NASA Ames Research Center                            Home: +1 408 866 1912
NAS: M/S 258-5                                       Work: +1 650 604 0935
Moffett Field, CA 94035                             Pager: +1 650 940 5942