Subject: Re: Serial port console
To: Matthew Jacob <>
From: Ted Spradley <>
List: port-alpha
Date: 08/02/1998 16:13:45
> 1) select the 'correct' console in /etc/ttys- the console pseudo-device
> doesn't seem to always do what I expect.

I think this is what finally straightened it out.  I had both 'console' 
and 'ttyC0' 'on' in /etc/ttys.

> 2) parity=none seems to be important.

Yeah, I was watching out for that.

> Can you get to single user (e.g., w/o boot flags set to 'a') and
> do things work well there? Other than this, it may be the h/w on
> this particular beast.

Yeah, it worked fine in single-user mode.

I should be able to change the 'off's and 'on's in /etc/ttys and 'kill -1 
1' to turn getty's on and off, shouldn't I?

Since I still had 1.3.2 on another disk, I booted that up and tried it.  
I never did get logged in on ttyC0, but when I moved the cable to ttyC1 
that worked just fine.  I could not get it to start a getty on ttyC0.

I booted up 1.3F and changed /etc/ttys to turn 'console' off and leave 
ttyC0 and ttyC1 on, 'kill -1 1', and it put up a getty and let me login 
on ttyC0 just fine.

It had me stumped for a while there, but it's working fine now.  I guess 
I should have paid attention to that comment in /etc/ttys:

# In normal operation, getty on 'console' pseudo-device is disabled, and 
# enabled for the correct 'real' device (e.g. one of the serial ports).

Thanks, guys!