Subject: Weirdness on latest Alpha snap.
To: None <port-alpha@NetBSD.ORG>
From: Kevin P. Neal <>
List: port-alpha
Date: 07/16/1998 16:52:24
Just downloaded the latest Alpha snap, the one with the June 30ith kernel.

I booted the new kernel without updating userland or my bootblocks. My
userland is 1.3 release and I think the boot block is 1.2-something. 

On the way up I saw some weirdness. On boot the kernel got as far as
checking for lpt0. It printed "lpt0 at isa0 port 0x3bc-0x3bf irq 7" and then
it just
sat there for, oh, 15-30 seconds or so. Then it continued.

It then got to the part where it allocated buffer headers for uvm. The next
message out was:

sd2(ncr0:3:0): error code 3
sd2(ncr0:3:0): error code 3   

My fsck then failed because it couldn't access the disk. When I got a shell,
I ran fsck again. It then said that the filesystem was clean and it wouldn't
be checked. ???

Alright. "# exit" and then it proceeded to boot with no other problems. 


The screen does look dimmer, but I'm on a 14" B&W monitor. Did the colors
change? Ho hum, whatever. 

BTW, does anybody have Amanda-2.4.0p1 binaries? I've got 2.3 binaries but
they won't work with my tape drive -- it bombs in 'taper' with errno==5 when
it tries to rewind the tape. I'll get to that after I finish my upgrade.
(Now that I think about it, the guy I got the drive from might have swapped
out the ROMs or something. Hmmm)

Anybody see any reason I shouldn't go ahead and finish my upgrade from 1.3?

Here's dmesg output of the bootup:

consinit: not using prom console
Copyright (c) 1996, 1997, 1998
    The NetBSD Foundation, Inc.  All rights reserved.
Copyright (c) 1982, 1986, 1989, 1991, 1993
    The Regents of the University of California.  All rights reserved.

NetBSD 1.3F (GENERIC) #1: Tue Jun 30 16:58:17 PDT 1998
AlphaStation 200 4/233, 233MHz
8192 byte page size, 1 processor.
real mem = 67108864 (2048000 reserved for PROM, 65060864 used by NetBSD)
avail mem = 54288384
using 794 buffers containing 6504448 bytes of memory
mainbus0 (root)
cpu0 at mainbus0: ID 0 (primary), 21064A (reserved minor type)
apecs0 at mainbus0: DECchip 21071 Core Logic chipset
apecs0: DC21071-CA pass 2, 64-bit memory bus
apecs0: DC21071-DA pass 2
pci0 at apecs0 bus 0
pci0: i/o enabled, memory enabled
ncr0 at pci0 dev 6 function 0: ncr 53c810 fast10 scsi
ncr0: interrupting at isa irq 11
ncr0: minsync=25, maxsync=206, maxoffs=8, 16 dwords burst, normal dma fifo
ncr0: single-ended, open drain IRQ driver
ncr0: restart (scsi reset).
scsibus0 at ncr0: 8 targets
sd0 at scsibus0 targ 0 lun 0: <DEC, RZ28M    (C) DEC, 0568> SCSI2 0/direct fixed
sd0(ncr0:0:0): 10.0 MB/s (100 ns, offset 8)
sd0: 2007MB, 3045 cyl, 16 head, 84 sec, 512 bytes/sect x 4110480 sectors
sd1 at scsibus0 targ 1 lun 0: <MICROP, 4345NV, AV10> SCSI2 0/direct fixed
sd1(ncr0:1:0): 10.0 MB/s (100 ns, offset 8)
sd1(ncr0:1:0): M_DISCONNECT received, but datapointer not saved:
        data=40c4ca00 save=40c476b0 goal=40c476d4.
sd1: 4340MB, 4811 cyl, 11 head, 167 sec, 512 bytes/sect x 8890029 sectors
sd2 at scsibus0 targ 3 lun 0: <QUANTUM, FIREBALL1080S, 1Q09> SCSI2 0/direct
sd2(ncr0:3:0): 10.0 MB/s (100 ns, offset 8)
sd2: 1042MB, 3835 cyl, 4 head, 139 sec, 512 bytes/sect x 2134305 sectors
st0 at scsibus0 targ 4 lun 0: <EXABYTE, EXB-8200, 262Z> SCSI1 1/sequential remov
st0: drive empty
sd3 at scsibus0 targ 5 lun 0: <SyQuest, SQ3105S, 3-14> SCSI2 0/direct removable
sd3(ncr0:5:0): 5.0 MB/s (200 ns, offset 8)
sd3: 105MB, 2060 cyl, 2 head, 52 sec, 512 bytes/sect x 215440 sectors
cd0 at scsibus0 targ 6 lun 0: <DEC, RRD45   (C) DEC, 0436> SCSI2 5/cdrom removab
probe(ncr0:6:1): 4.0 MB/s (250 ns, offset 8)
sio0 at pci0 dev 7 function 0: Intel 82378ZB System I/O (SIO) (rev. 0x43)
de0 at pci0 dev 11 function 0
de0: interrupting at isa irq 5
de0: DEC 21040 [10Mb/s] pass 2.4
de0: address 00:00:f8:23:5c:7b
de0: enabling 10baseT port
vga0 at pci0 dev 13 function 0: S3 Trio32/64 (rev. 0x00)
wsdisplay0 at vga0: console (80x25, sun emulation)
isa0 at sio0
com0 at isa0 port 0x3f8-0x3ff irq 4: ns16550a, working fifo
com1 at isa0 port 0x2f8-0x2ff irq 3: ns16550a, working fifo
lpt0 at isa0 port 0x3bc-0x3bf irq 7
pckbc0 at isa0 port 0x60-0x64
pckbd0 at pckbc0 (kbd slot)
wskbd0 at pckbd0: console keyboard
pcppi0 at isa0 port 0x61
spkr0 at pcppi0
mcclock0 at isa0 port 0x70-0x71: mc146818 or compatible
wscons: wskbd0 glued to wsdisplay0 (console)
root on sd1a dumps on sd1b
sd1(ncr0:1:0): M_DISCONNECT received, but datapointer not saved:
        data=40c4c200 save=40c476b0 goal=40c476d4.
sd1(ncr0:1:0): M_DISCONNECT received, but datapointer not saved:
        data=40c4c200 save=40c476b0 goal=40c476d4.
sd1(ncr0:1:0): M_DISCONNECT received, but datapointer not saved:
        data=40c4c200 save=40c476b0 goal=40c476d4.
root file system type: ffs
uvm_swap: allocated 256 swap buffer headers
sd2(ncr0:3:0): error code 3
sd2(ncr0:3:0): error code 3
de0: enabling 10baseT port

Thanks guys.
Kevin P. Neal                

'You know, I think I can hear the machine screaming from here... \
"help me! hellpp meeeee!"' - Heather Flanagan, 14:52:23 Wed Jun 10 1998