Subject: Re: can't compile kernel
To: Berndt Josef Wulf <>
From: Chris G Demetriou <Chris_G_Demetriou@UX2.SP.CS.CMU.EDU>
List: port-alpha
Date: 04/30/1996 23:55:35
> The old problems remain -
> 	no nfs to a netbsd/alpha partition
>  	showmount -	RPC: portmapper failure
>                         :Can't do Mountdump rpc
>                         showmount exited with status 1

So, i just tried these.  Actually, i noticed that portmap was
occasionally dumping core, and I tracked down why, and then I tried
them, so I don't really know if I fixed the bug or never would have
seen it...

Anyway, with the diff below applied to portmap (I can't check it in
right now, since the NetBSD.ORG CVS machine is down...), I was able
	(1) do showmount from another machine 'pointed at' a
	    NetBSD/Alpha machine (for all variations of showmount),
	(2) mount, via both NFS v2 and v3, the partition that the
	    NetBSD/Alpha machine was exporting.

I tried these tests from NetBSD/i386 and Digital UNIX.  (Those are the
only systems I have access to.)

If you're still having problems once you've applied this fix,
recompiled and installed portmap, and restarted the various daemons
(mountd, nfsd), etc., then I'm apparently not able to replicate your
problem with the systems i've tested.

*** /tmp/portmap.c	Tue Apr 30 23:46:31 1996
--- ./portmap.c	Tue Apr 30 23:22:25 1996
*** 230,236 ****
  	struct pmap reg;
  	struct pmaplist *pml, *prevpml, *fnd;
! 	int ans, port;
  	caddr_t t;
  	if (debugging)
--- 230,236 ----
  	struct pmap reg;
  	struct pmaplist *pml, *prevpml, *fnd;
! 	long ans, port;
  	caddr_t t;
  	if (debugging)