Subject: Acorn NC installation kernels
To: None <>
From: Theo Markettos <>
List: port-acorn32
Date: 11/22/2007 14:07:34
I'm trying to install NetBSD on an Acorn NetStation NC with 16MB RAM.

I've followed the netboot instructions in the NetBSD/acorn32 FAQ and have
boot32 loading a kernel from NCOS, booting the kernel and printing NetBSD
output in white on black.  So it's booting OK and the NFS server is working,
I think.  One complication is that my NFS server is on a different machine
from dhcpd, so I use the next-server option to tell the NC to NFS mount the
second machine.  It work for NCOS.

I then followed these instructions to unpack the 3.1 base sets into my NFS root:

I've tried most of the kernels in the*/acorn32/binary/kernel trees.

Most of the 2.x/3.x kernels get as far as discovering there's NFS root,
doing DHCP and then deciding to hang or reboot.  Below is the screen output. 
It flashes past so fast I had to transcribe it from my camera so the right
side of the output is missing and there are some bits I can't see clearly.

I've got a 2.0.2 installation kernel to take me to the install menu, but I
don't have any hard drives I can install onto!  I can, however, configure
the network then drop onto the command line and mount the NFS share with no
# mount /targetroot

If I run the 2.0.2 GENERIC kernel it prompts me for root and dump devices
and a filesystem, but when I supply 'ne0', 'none' and 'nfs' respectively it
claims it can't find anything (not surprising since it doesn't have an IP

I even tried an ancient 1.3_alpha RPCINST kernel, but boot32 refused to boot

Any suggestions?


[recording starts]
mainbus0 (root)
cpu at mainbus0: ARM7500 rev 0 (
cpu0: IOC enabled WB enabled EABI
cpu0: 4kB/16B 4-way write through
iomd0 at mainbus0: ARM7500 IOMD version
iomd0: DRAM refresh=16us
clock0 at iomd0
kbd0 at iomd0
iomdiic0 at iomd0
iic0 at iomdiic0: I2C bus
pcfrtc0 at iic0 addr 0x50: PCF8583 Real-time
pcfrtc0: unable to read CSR
iomdkbd0 at iomd0
dma0 at iomdkbc0 (aux slot)
wsmouse0 at pma0 mux 0
vidc0 at mainbus0: ARM7500 video
vidcaudio0 at vidc0: 16-bit extern
audio0 at vidcaudio0: half-duplex
aurateconv: encoding/precision must not be cha
audio attach: audio_set_default() failed
vidcconsole0 at vidc0: refclk=32MHz 472KB DRAM
vt0 at vidc0: console driver [V203E] using vt
vt1 at vidc0: console driver [V203E] using vt
podulebus0 (root)
podule0 at podulebus0: Irlam Instrument:
ne0 at podulebus0 slot 0: EtherN ethernet
ne0: Ethernet address 00:00:a4:11:46:06
ne0: 10baseT, default 10baseT
ne0: NE2000 chipset, 16 Kb memory
ipl_bio=8100a008 ipl_net=81008008 ipl_tty=800
ipl_audio=00000000 ipl_imp=00000000 ipl_high=
lock: hz=100 stathz = 0 profhz = 0
etting statclock to 0Hz (-1 ticks)
d0: allocated 0K (0 blocks)
boot device: <unknown>
root on ne0
nfs_boot: trying DHCP/BOOTP
nfs_boot: DHCP next-server
nfs_boot: my_name=india
nfs_boot: my_addr=
nfs_boot: my_mask=
nfs_boot: gateway=
root on
warning: no /dev/console
ne0: warning = receiver ring buffer overrun
ne0: warning = receiver ring buffer overrun
panic: Reset vector called, LR = 0xf00f5778
?oot: howto=00000100 curlup=0xf22ec45c
?pl_bio=8100a025 ipl_net=81008028 ipl_tty=800
?pl_audio=00000020 ipl_clock=00000000 ipl_no
?pl_mask[0]=ffffffff splsmask[0]=ffffffff
?pl_mask[1]=ffffffff splsmask[1]=00000006
?pl_mask[2]=ffffffff splsmask[2]=00000004
?pl_mask[3]=8100a028 splsmask[3]=00000004
?pl_mask[4]=8100a028 splsmask[4]=00000004
?pl_mask[5]=80000020 splsmask[5]=00000000
?pl_mask[6]=80000020 splsmask[6]=00000000
?pl_mask[7]=80000020 splsmask[7]=00000000
?pl_mask[8]=00000020 splsmask[8]=00000000
?pl_mask[9]=?0000000 splsmask[9]=??000000
?pl_mask[10]=00000000 splsmask[10]=00000000
?pl_mask[11]=00000000 splsmask[11]=00000000
?pl_mask[12]=0000000? splsmask[12]=00000000
???oing disk... done
[NC reboots]