Subject: Re: IMPORTANT NOTE : Installation assistance
To: None <,>
From: Peter Bell <>
List: port-acorn32
Date: 03/27/2002 16:11:21
In message <20020327012900.A2691@rangerover.kasbah>
          Reinoud Zandijk <> wrote:

Reinoud, thanks for your detailed response.

> Dear Peter and all who read with him on these mailing lists,
> On Tue, Mar 26, 2002 at 10:39:16PM +0000, Peter Bell wrote:
> > I'm attempting to get BSD up and running on the following
> > configuration:
> > 
> > RiscPC 600 with SA revT
> > RISC OS 3.7
> > 16MB RAM
> > 1MB VRAM
> > EtherLan 500 (EtherH), [with adsl gateway on lan]
> > ideA (Arcin V6) IDE interface with empty IBM 44GB master drive
> > 205GB Conner on ADFS::4 (totally dedicated to RO)

Yes, as you remark, that should be 205MB.!

> > Firstly, I'm unclear whether I should be using arm32 or acorn32
> > distributions - any advice?
> This is part of a restructuring of all ARM ports in the transition from 
> NetBSD-1.5.x to NetBSD-1.6.
> The older one is arm32 ... this used to cover all kinds of ARM based ports,
> this was split up for maintenance reasons into port-acorn32, port-shark,
> port-hpcarm, port-cats etc..
> So for NetBSD-1.5.2 or the forthcoming NetBSD-1.5.3 you'll need the 
> port-arm32, for all newer versions you'll have to use port-acorn32.
> Since NetBSD-1.6 hasn't rolled out yet there is no snapshot i can give
> you... technically NetBSD/acorn32 hasn't been released yet. I could give
> you a snapshot now of the -current branch but you'll be in trouble then for
> things are likely still to change... it might make your installation
> problematic.

Okay, so for the time being, I stick to arm32.

> _However_
> You can use the BtNetBSD on's
> /pub/NetBSD/arch/acorn32/riscos/* but you'll have to put in
> `oldkernel' as one of the options if you decide  to run NetBSD-1.5.x
> on it... or it won't work :(

The old Bt application would seem to be a little friendlier, in that
all the configuration can be performed through a nice front end,
whereas the new one seems to require manual editing of the config

> There you can also find the in the 1.5.2 release missing prep.RISCOS and
> the INSTALL.* docs (!)
> > Secondly, as I read through INSTALL.txt files they advise me to
> > 'perform the instructions in arm32/platform/prep that are specific to
> > your platform'.  Where do I find 'arm32/platform/prep'?  Is this
> > somewhere on  Am I meant to start of in
> > /pub/NetBSD/NetBSD-1.5.2, or somewhere in /pub/NetBSD/arch?  I cannot
> > find any directories called 'platform' - is this supposed to be
> > substituted by 'riscos'?
> thats the prep.RISCOS file in /pub/NetBSD/arch/acorn32, and yes the 
> `platform' is to be renamed by `sparc', `alpha', `acorn32', `shark', etc. 
> i.e. not the operating system origionally run on it.

Right, thanks.  This document, although dated 2002/03/12 still seems
to refer to bb_trash and describes the /very/ old bb_riscbsd which
only knew about ADFS and SCSI (and required editing to handle the
Acorn SCSI card).

> > Thirdly, if I ignore the fact that I haven't been able to find the
> > platform-specific instructions and go ahead to try to get something
> > running, I run bb_(net/risc)bsd - I want to dedicate the whole of the
> > 44GB disc on IDEFS - so I specify a starting cylinder of 0 on IDEFS
> > drive 4.  That's fine but I can't get mountufs to mount the partition.
> > Should the command be 'mountufs IDEFS 4' or 'mountufs IDEFS wd0a'.
> > There seems to be some confusion over this in the files which I have
> > fetched from the ftp site.  In any case, both commands fail, wd0a
> > produces 'Disc drive not known', 4 produces 'Bad disklabel'.
> Thats good ... the `mountufs IDEFS 4' is the good one ... It reports a `bad 
> disklabel' for the NetBSD partition is made OK but it isn't fomatted or 
> whatever ... thats where the disclabel comes it... it describes the 
> partitioning of the NetBSD part of the harddisc.
> > If I ignore mounting the ufs partition, and attempt to load a kernel
> > from the RISC OS drive, after reporting memory configuration, BtNetBSD
> > produces a message about 825 pages needing relocation and then bombs
> > out with a 'Can't use array reference here at line 2580'.
> Hope this isnt occuring anymore ! ... hmm... i wonder how it can happen... 
> if it happends again.... _please_ send a problem report to me or on the 
> problem report section of the NetBSD homepage... so we can solve this ASAP.

Well, I have managed to reproduce that symptom this morning, but
probably when messing about with different kernels/boot loaders.  I'll
have a go at it later, and attemp to report the exact circumstances.

> > If I attempt to run !BtRiscBSD, after ignoring the mountufs failure, I
> > get to a situation where the kernel actually starts up, reports lots
> > of info about the machine config, including finding the Conner 205MB
> > drive (as wd0), and reports of the EtherLan at podule0 and the IDE &
> > CDFS expansion card at podule1, but doesn't appear to find the 44GB
> > drive on podule1.  Obvioulsy, since there is no accessible unix
> > partition, the kernel then loops around asking for root and dump
> > devices and reports invalid partition format on wd0, ending with an
> > 'error = 79'.
> Thats because you haven't specified what the root is ... for installation
> purposes there is an explicit _installation kernel_ you can use from a RISC
> OS filingsystem that doesn't need an installed NetBSD harddisc to boot
> from. The `error = 79' is too cryptic i must agree but signals that there
> is not NetBSD partion found on that wd0 disc.

Right, so attempting to boot from an installation kernel
- this is obviously a gzip, which I unzip with SparkFS, but it
produces another file which is also typed as a gzip and cannot be
dragged onto the BtRiscBSD config window) I end up with a screen full
of vertical stripes of various shades of grey, with a white block
cursor which will jump around between about 5 different positions on
the screen, depending on key-presses on the keyboard.  I cannot help
but think that I am almost there, but it would be helpful to see
something more meaningful on the screen!

> Does it say anything other than noting the interface on podule1 ? i.e.
> attaching something on it ? or does it say `not configured' ?

It reports not configured, but I am not sure which kernel I was using
at the time.

> One thing you could do is to put the 44 Gb disk as a slave to the 205 Mb 
> disc (or was it 205 Gb ;) big) ... or vice versa ... the onboard IDE is 
> supported for sure !

Okay. I've done this, but it doesn't seem to help.  I can run
bb_(risc/net)bsd, but I still get bad disklabel and total failure to
mount. :(

> > Am I being stupid?  What do I need to do to get BSD going?
> No no you are not ... you just happend to find a port in a big flux :-)  
> this is both a good sign but also not that handy if you want to install a
> fresh NetBSD system ... The release planned for 1.6 (maybe even this week
> in beta?) is much better prepared than the 1.5 release.... partly for the 
> origional port-arm32 maintainer left without ensuring a successor ... that 
> didnt help :-/
> Hope this helped... it has become a big document but i really hope ppl.  
> will find this helpfull ... am also planning to put up a piece on the 
> website on this but that also takes some time and i'd rather have something 
> to release then too ....

Okay, well I /think/ that it has helped, but I still can't get an
acceptable disklabel on my 44GB drive, and I am getting an
installation kernel booted but without anything sensible on the
screen.  Does it help to see my configuration files?

Peter Bell -