pkgsrc-WIP-review archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

`_ZNSsD1Ev' can not be used when making a shared object; recompile with -fPIC

I am attempting to build clang 3.0.99, as currently in pkgsrc-wip.
The build is interrupted by complaints about -fPIC, which *is* used.
The above discussion indicates a problem with "visibility".  

I tried deleting the offending .o and restarting the build.  That
inexplicably worked the first time the problem cropped up, but not for
the next file, Indexing.o:

gmake[4]: Leaving directory
`/usr/pkgsrc/wip/clang/work/llvm/tools/clang/tools/driver' gmake[4]:
Entering directory
`/usr/pkgsrc/wip/clang/work/llvm/tools/clang/tools/libclang' llvm[4]:
Linking Release Shared Library
relocation R_X86_64_PC32 against `_ZNSsD1Ev' can not be used when
making a shared object; recompile with -fPIC ld: final link failed: Bad
value gmake[4]: ***
[/usr/pkgsrc/wip/clang/work/llvm/Release/lib/] Error 1

Apparently this is something that works for 32-bit mode but sometimes
not in 64-bit.  Suggestions?  

$ gcc -v
Using built-in specs.
Target: x86_64--netbsd
Configured with: /usr/src/tools/gcc/../../gnu/dist/gcc4/configure
--enable-long-long --disable-multilib --enable-threads
--disable-symvers --build=x86_64-unknown-netbsd4.99.72
--host=x86_64--netbsd --target=x86_64--netbsd --enable-__cxa_atexit
Thread model: posix 
gcc version 4.1.3 20080704 prerelease (NetBSD nb2 20081120)


For Developers, A Lot Can Happen In A Second.
Boundary is the first to Know...and Tell You.
Monitor Your Applications in Ultra-Fine Resolution. Try it FREE!
pkgsrc-wip-review mailing list

Home | Main Index | Thread Index | Old Index