pkgsrc-WIP-cvs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

CVS commit: wip/libupnp

Module name:    wip
Committed by:   obache
Date:           Fri Apr 27 17:27:39 UTC 2007

Modified Files:
        wip/libupnp: Makefile distinfo
        wip/libupnp/patches: patch-aa patch-ac patch-ad patch-ae patch-ag
Removed Files:
        wip/libupnp/patches: patch-af patch-ah

Log Message:
Update libupnp to 1.4.4.

Version 1.4.4

2007-04-06 Marcelo Jimenez <mroberto(at)>
        * SF Tracker [ 1695399 ] Typo in util.h
        Submitted By: Luke Kim - nereusuj
        Unix sleep is in seconds but WIN32 Sleep is in milliseconds.

2007-04-17 Marcelo Jimenez <mroberto(at)>
        * SF Tracker [ 1652827 ] UpnpRegisterRootDevice returned -104
        Submitted By: Michael Andersen - miwer
        Issue was found to be related to sizeof (size_t) != sizeof (int)
        on AMD64 systems. Emil Ljungdahl's AMD64 patch has been applied along
        with some other fixes. Original user report follows:

        When I run upnpd I get the above mentioned error (UPNP_E_OUTOF_MEMORY).
        I've tried with 1.4.1 and 1.4.2-RC3, it's the same. I don't understand 
        because I have plenty of RAM, and I even tried closing some 
        but it didn't help.

        $ upnpd eth1 br0

        The following is logged in the /var/log/messages:
        Feb 6 01:33:47 server upnpd[6933]: Error registering the root device 
        Feb 6 01:33:47 server upnpd[6933]: UpnpRegisterRootDevice returned -104

        I tried enabling debugging and it looks like it cannot allocate memory
        through the membuffer_append function. It's wierd because it's only a 

        Please note, that I enabled some extra debugging lines that were 
        in order to get more information. See attached files.

To generate a diff of this commit:
cvs -z3 rdiff -u -r1.11 -r1.12 wip/libupnp/Makefile
cvs -z3 rdiff -u -r1.3 -r0 wip/libupnp/patches/patch-ah
cvs -z3 rdiff -u -r1.3 -r1.4 wip/libupnp/patches/patch-ad \
cvs -z3 rdiff -u -r1.4 -r1.5 wip/libupnp/patches/patch-ac \
cvs -z3 rdiff -u -r1.5 -r0 wip/libupnp/patches/patch-af
cvs -z3 rdiff -u -r1.5 -r1.6 wip/libupnp/patches/patch-aa
cvs -z3 rdiff -u -r1.8 -r1.9 wip/libupnp/distinfo

To view a diff of this commit:

Please note that diffs are not public domain; they are subject to the
copyright notices on the relevant files.

This email is sponsored by DB2 Express
Download DB2 Express C - the FREE version of DB2 express and take
control of your XML. No limits. Just data. Click to get it now.
pkgsrc-wip-cvs mailing list

Home | Main Index | Thread Index | Old Index