Subject: Re: updating multimedia/ns-flash and sound problems
To: None <>
From: Chavdar Ivanov <>
List: pkgsrc-users
Date: 12/16/2007 20:36:41
On 16/12/2007, Jukka Salmi <> wrote:
> Hello,


> after I've seen Juan RP's recent [1]commit to multimedia/ns-flash I
> tried to build the package on a NetBSD/i386 4.99.34 system. This
> initially failed because the distfile's checksum was out of date, and
> building with NO_CHECKSUM=yes failed because the package doesn't contain
> `flashplayer.xpt' (anymore?).
> Not being sure how to proceed, I changed some files (see attached diff)
> until building succeeded. However, I'm not sure whether ${FLASH_VERS}
> should be 9.0r60 or 9.60r0, and I don't know what the package should
> do with ${LOCALBASE}/lib/firefox/components/xpti.dat - the
> `flashplayer-installer' script shipping with the distfile just removes
> it.

I had already working ns-flash 9.0.31. I applied your patch and
updated to 9.0.60 without any problems. Sound works fine - just as
before. This is on -current (4.99.42 from yesterday), firefox

I don't know anything about the .xpt file, but it seems to be working
fine without it.

> Once the package was built and installed I started (native) firefox
> (, and indeed, I was able to watch flash movies on youtube!
> But unfortunately there was no sound. Is this expected behaviour?
> Regards, Jukka
> [1]
> --
> bashian roulette:
> $ ((RANDOM%6)) || rm -rf ~

/dev/random says:

	Predestination was doomed from the start.
Chavdar Ivanov   | Talbot Way, Small Heath Business Park
Delcam UK        | Birmingham B10 0HJ, United Kingdom
Customer Support | (+44)121-6831014