Subject: Re: gnome-settings-daemon problem
To: None <>
From: David H. Gutteridge <>
List: pkgsrc-users
Date: 12/04/2007 21:39:22
Dennis den Brok wrote:
>Huub <> schrieb:
>>Huub wrote:
>>>Running NetBSD 3.1/i386, for some reason I get the message 
>>>"gnome-settings-daemon" when I start gnome or want to adjust settings. 
>>>Also, some icons have disappeared. How can I solve this? What packages 
>>>should I check with pkg_info (and how to compare installed vs. 
>>Correction: message is "Unable to start the settings manager 
>Random guess: Make sure you have dbus, famd and rpcbind running.
>Cf. /usr/pkg/share/examples/rc.d.

I'm seeing this problem on a clean install of NetBSD 4.0_RC5/macppc.
I searched through Google and see many Linux users complaining of this
issue over the past three years, with various suggested remedies,
including the one above, deleting directories under $HOME like .gconfd,
rebooting (hah!), manually starting the gconfd daemon, starting other
daemons that pkgsrc doesn't include (at least, not under the same name),
etc.  Nothing so far has worked for me.  The best lead I have to go on
was one user who indicated it was due to problems with liboil.
(Something about the Gnome settings daemon needing to use GStreamer,
which in turn depends upon liboil.)  There are definitely problems with
the code generated by liboil on PowerPC targets, so that could be what's
causing this, but apparently this is happening on i386 as well, so
perhaps not.

I'm not sure how brave I feel about plunging into this one, I'm half-
tempted to switch to KDE and see if that works, I've never tried it on
the macppc port before.