Subject: problem when building chat/finch
To: None <>
From: Jan Kryl <>
List: pkgsrc-users
Date: 12/01/2007 13:20:07

I wasn't able to build finch (console front-end for libpurple), when
libpurple had been built with dbus support. The linker could not find
libdbus-glib-1 library (and it really wasn't present in work/.buildlink
directory). I added the following in in chat/libpurple and
it solved my problem:


pkgbase := libpurple
.include "../../mk/"

.if !empty(PKG_BUILD_OPTIONS.libpurple:Mdbus)
.  include "../../sysutils/dbus/"
.  include "../../sysutils/dbus-glib/"


However my knowledge of pkgsrc is very limited and I don't know if this
is appropriate fix. Please review.


PS: Almost forgot to say which version of it was:
    $NetBSD:,v 1.4 2007/11/03 15:59:18 tnn Exp $