Subject: ap-php with php5, apache22 and --enable-maintainer-zts ?
To: None <>
From: Jeff Rizzo <>
List: pkgsrc-users
Date: 10/24/2007 17:13:07

I'm probably just doing something odd, but building www/ap-php isn't
working for me right now:

=> Modifying libtool scripts to use pkgsrc libtool
===> Building for ap22-php5-5.2.4nb1
/bin/sh /usr/pkgsrc/www/ap-php/work.i386/php-5.2.4/libtool --silent
--preserve-dup-deps --mode=compile
/usr/pkgsrc/www/ap-php/work.i386/php-5.2.4/meta_ccld  -Iext/libxml/
-I/usr/pkgsrc/www/ap-php/work.i386/php-5.2.4/ext/libxml/ -DPHP_ATOM_INC
-I/usr/pkgsrc/www/ap-php/work.i386/php-5.2.4 -I/usr/pkg/include/libxml2
-I/usr/pkgsrc/www/ap-php/work.i386/php-5.2.4/Zend  -I/usr/include
-I/usr/pkg/include -I/usr/pkg/include/apr-1 -I/usr/pkg/include  -O2
-I/usr/include -I/usr/pkg/include -I/usr/pkg/include/apr-1 -pthread
-DZTS   -c
/usr/pkgsrc/www/ap-php/work.i386/php-5.2.4/ext/libxml/libxml.c -o
libtool: compile: unable to infer tagged configuration
libtool: compile: specify a tag with `--tag'
*** Error code 1

I have apache-2.2.6nb1 and php-5.2.4nb3 packages installed, and the only
oddnesses are that APACHE_MPM is set to "worker", and I added (by hand)
--enable-maintainer-zts to the php CONFIGURE_ARGS when I built it so
that it would *work* with the worker MPM.

This is a very up-to-date pkgsrc (20 minutes ago) - any suggestions?  Am
I doing something dumb?

This is on NetBSD/i386 4.0_RC3, if it matters...

Please CC: me on any responses...