Subject: Re: different version requirements for source vs. pre-built binaries?
To: Steven M. Bellovin <>
From: Jeremy C. Reed <>
List: pkgsrc-users
Date: 10/24/2007 14:20:15
On Wed, 24 Oct 2007, Steven M. Bellovin wrote:

> For some packages I maintain -- claws-mail and its plug-ins -- all
> plug-ins must be compiled with the base package.  However, the versions
> may or may not need to match.  For example, the trayicon plug-in is at
> 3.0.1; that source can be compiled with either 3.0.1 or 3.0.2 of
> claws-mail itself.  However, a binary that runs with claws-mail 3.0.2
> must have been compiled with a 3.0.2 base system.  Is there any way to
> capture this in the Makefile?  Or should I just bump the dependency and
> PKGREVISION for traiyicon, even though it hasn't changed?

Looks like some plugins use
.include "../../mail/claws-mail/"

and some do not. Maybe use that for all that need it.

And as applicable do:

BUILDLINK_API_DEPENDS.claws-mail+= claws-mail>=3.0.1
BUILDLINK_ABI_DEPENDS.claws-mail+= claws-mail>=${CLAWS_VERSION}

(Not tested, just an idea ...)

  Jeremy C. Reed