Subject: Re: Can we get mail/spamprobe updated?
To: Hubert Feyrer <>
From: Chris Ross <>
List: pkgsrc-users
Date: 10/24/2007 10:57:06
On Oct 24, 2007, at 06:56, Hubert Feyrer wrote:
> [CC:d the spamprobe maintainer]

   Thanks.  Where are those mappings recorded?  I generally just draw  
from the CVS logs.  :-)

> Sure.
> I can't do any testing beyond installing right now. Please test the  
> patch below, and let me know if the resulting package works for  
> you, within the next few days. I can commit it then, as soon as I  
> get your OK.

   The patch you supplied builds, installs, and works for initial  
testing.  I have an established DB4 database, and it's able to access  
that, score emails, etc.  Seems just fine.

   Also, mail/spamprobe/patches/patch-aa is no longer needed.  It  
builds just fine without it, so please remove it when this update  
gets committed.

>> (Also, did it have to be re-named/versioned to 1.4.2 in pkgsrc?   
>> Does pkgsrc versioning for the source product not support "1.4b"  
>> type versioning?)
> Apparently it does:
> 	yui% pkg_admin pmatch 'foo>1.4b' 'foo-1.4c' ; echo $?
> 	0
> 	yui% pkg_admin pmatch 'foo>1.4b' 'foo-1.4a' ; echo $?
> 	1
> ... works as well. I have NFI why the scheme was chosen. :(
> Geert?

   Okay.  I'd like to wait to figure this out before we update what's  
committed, but it's ready to go with your patch and the removal of  
patches/patch-aa.  Thanks!

                     - Chris