Subject: xine buildlink issue -- revisited
To: None <>
From: Sverre Froyen <>
List: pkgsrc-users
Date: 10/23/2007 15:37:24

I'm still getting errors trying to start artsd.  It's the same error that was 
reported in a tech-pkg thread about a month ago:

/usr/pkg/lib/ Undefined PLT symbol "ao_new_port" (symnum = 

This is after building all packages from a pkgsrc tree cvs'd on 20 Oct. The 
tech-pkg thread indicated that the problem could be solved by upgrading to 
xine-arts-1.1.7nb1  As far as I can tell, I have the corrected version:

$ pkg_info | egrep 'arts|xine|libao'
arts-1.5.8          Analog Real-Time Synthesizer
xine-lib-1.1.7      Multimedia player library
libao-0.8.6nb4      Cross-platform audio library
libao-oss-0.8.6nb1  Cross-platform audio library (OSS plugin)
xine-arts-1.1.7nb1  The aRts audio output plugin for xine-lib

Interestingly, libao-oss was installed as a prerequisite for xine-arts:

$ pkg_info -R libao-oss-0.8.6nb1
Information for libao-oss-0.8.6nb1:

Required by:

I would have expected to see libao-arts instead of libao-oss.

I also installed libao-oss (but without rebuilding anything else):

libao-arts-0.8.6nb3 Cross-platform audio library (arts plugin)

without any apparent effect.