Subject: Re: problem with BUILDLINK_PREFIX.package on Linux
To: None <>
From: Ondrej Tuma <>
List: pkgsrc-users
Date: 10/08/2007 20:52:26
Content-Type: text/plain; charset=US-ASCII
Content-Transfer-Encoding: quoted-printable

I have this problem in pkgsrc from 03.09.07 :(
i use these "native" tools:
aaa_base-1.4.0-noarch-0  floppy-5.4-i386-3                 less-394-i586-1 =
acpid-1.0.4-i586-2       gawk-3.1.5-i586-3                 libtermcap-1.2.3=
-i586-7         reiserfsprogs-3.6.19-i586-1
bash-3.1.017-i586-1      gcc-3.4.6-i586-1                  lilo-22.7.1-i586=
-2              sed-4.1.5-i586-1
bin-11.0-i586-3          gcc-g++-3.4.6-i586-1              logrotate-3.7.4-=
i586-1          shadow-
bin86-0.16.17-i586-1     glibc-2.5-i586-1                  make-3.81-i586-1=
binutils-2.17-i586-1     gpm-1.20.1-i486-2                 man-1.6e-i586-1 =
byacc-20070509-i586-1    grep-2.5-i586-3                   man-pages-2.39-n=
oarch-1         sudo-1.6.8p12-i586-1
bzip2-1.0.3-i586-3       groff-1.19.2-i586-1               mdadm-2.5.3-i586=
-1              sysfsutils-2.0.0-i586-2
coreutils-6.7-i586-1     gzip-1.3.5-i586-1                 mkinitrd-1.0.1-i=
586-3           sysklogd-1.4.1-i586-9
db1-1.85-i586-1          hdparm-6.6-i586-1                 module-init-tool=
s-3.2.2-i586-2  syslinux-2.13-i586-1
dcron-2.3.3-i586-5       hotplug-2004_09_23-noarch-11      ncurses-5.5-i586=
-1              sysstat-7.0.0-i586-1
dhcp-3.0.4-i586-2        inetd-1.79s-i586-7                nfs-utils-1.0.10=
-i486-3         sysvinit-2.84-i586-69
dhcpcd-2.0.4-i586-2      iproute2-2.6.16_060323-i586-1     pciutils-2.2.3-i=
586-2           tar-1.15.1-i586-2
diffutils-2.8.1-i586-3   iptables-1.3.5-i586-2             pcmciautils-014-=
i586-2          tcpip-0.17-i586-39
e2fsprogs-1.39-i586-2    iptraf-2.7.0-i586-1               pkgtools-1.4.0-i=
586-4           traceroute-1.4a12-i586-2
elvis-2.2_0-i586-2       isapnptools-1.26-i586-1           popt-1.7-i586-1 =
etc-1.4.0-noarch-0       jfsutils-1.1.11-i586-1            portmap-5.0-i586=
-3              util-linux-2.12r-i486-5
findutils-4.2.28-i586-1  kbd-1.12-i586-2                   ppp-2.4.4-i586-1
flex-2.5.4a-i586-3       kernel-headers-  procps-3.2.7-i58=

On Mon, 8 Oct 2007 20:43:40 +0200
Ondrej Tuma <> wrote:

> Hi,
> i don't know why, but i have problems with BUILDLINK_*_.${_pkg_}
> variable in Makefiles. I have some problems with openssl, so i found,
> that the problem is in that Makefiles don't work right for me.
> I have current version of pkgsrc, mk/* without any modification and
> current bmake, for example, in security/qca-tls:
> ondra@jim:/usr/pkgsrc/security/qca-tls$ bmake show-var
> openssl qt3-tools qt3-libs glu MesaLib mng jpeg lcms png libXcursor
> libXfixes fixesproto libXft fontconfig iconv zlib expat freetype2
> libXrender renderproto libXmu libXt libSM libICE libXrandr randrproto
> libXinerama libXext xextproto inputproto xineramaproto libX11 kbproto
> libXau libXdmcp xproto pthread
> ondra@jim:/usr/pkgsrc/security/qca-tls$ bmake show-var
> VARNAME=3DBUILDLINK_DEPENDS openssl qt3-libs qt3-tools
> but=20
> bmake show-var VARNAME=3DSSLBASE
> (_empty line_)
> SSLBASE would be ${BUILDLINK_PREFIX.openssl}
> i test this variables in many packges by CONFIGURE_ARGS or
> CONFIGURE_ENVS or any other, wher it's possible, and still nothing :(
> I don't know when this problem starts, in my opinion one, two, three
> weeks ago ?=20
> Do you someone know, when can i find the problem ?=20
> Thanks a lot.
> --=20
> Ondrej Tuma
>    Www:,
> Jabber:

Ondrej Tuma


Content-Type: application/pgp-signature; name=signature.asc
Content-Disposition: attachment; filename=signature.asc

Version: GnuPG v1.4.7 (GNU/Linux)