Subject: Re: Updating pkg_install on NetBSD 4
To: None <>
From: John Nemeth <>
List: pkgsrc-users
Date: 09/24/2007 19:33:59
On Feb 14,  2:08pm, Christian Hattemer wrote:
} John Nemeth wrote:
} > } Are there plans to remove the old tools from base then? I think this would 
} > 
} >      There are certainly people that would like to do this.
} > 
} > } be a good idea.
} > 
} >      I disagree that it would be a good idea.  pkgsrc is NetBSD's
} > packaging system.  It MUST be seemless to use it.
} Why not use the bootstrap feature also on NetBSD itself?

     Why should a NetBSD user have to do this for NetBSD's native
packaging system?

} Or maybe include the files that make up the package pkg_install and 
} /var/db/pkg in the base set (or maybe a pkgsrc set), so that a fresh 
} installed system already has one package with the tools installed. However 
} this sounds ugly.

     Yeah, it does, and could cause problems.

} But the current solution with the PATH hacking mentioned in the other mail 
} isn't less ugly and should be fixed before NetBSD 4.0 is released, to be 
} able to include pullups that may be necessary for the fix.
} If you don't do the PATH hack and the tools installed by the package become 
} incompatible with the old ones in /usr/sbin you may experience strange 
} results, or an error message in the best case. This isn't seemless either...

     Yes, this is big time broken...

}-- End of excerpt from Christian Hattemer