Subject: Re: Help! apache22, mod_perl, apr, apr-util, ap2-auth-mysql (NetBSD
To: None <pkgsrc-users@NetBSD.org>
From: Paul Newhouse <firstname.lastname@example.org>
Date: 09/24/2007 10:50:30
> There are two incompatible versions of apr in pkgsrc. apache22 uses the
> new one (1), and apache20 uses 0.9. there is code in
> /usr/pkgsrc/mk/apache.mk to manage which one, and it looks like
> something isn't quite right. You might try
> in mk.conf
> and see if ap2-perl then uses apr 1.
That change makes it decide it wants to install apr-0.9. Which doesn't seem
right at all.
=> Required installed package libtool-base>=1.5.18nb5: libtool-base-1.5.22nb4
=> Required installed package pkg-config>=0.19: pkg-config-0.21 found
=> Required installed package perl>=5.0: perl-5.8.8nb3 found
=> Required installed package apr-0.9.*: NOT found
=> Verifying reinstall for ../../devel/apr0
=> Required installed package digest>=20010302: digest-20060826 found
===> Checking for vulnerabilities in apr-0.9.16.2.0.61
===> Installing for apr-0.9.16.2.0.61
ERROR: apr-220.127.116.11.2.4nb1 is already installed - perhaps an older version?
ERROR: If so, you may use either of:
ERROR: - "pkg_delete apr-18.104.22.168.2.4nb1" and "/usr/bin/make reinstall"
ERROR: to upgrade properly
ERROR: - "/usr/bin/make update" to rebuild the package and all
ERROR: of its dependencies
ERROR: - "/usr/bin/make replace" to replace only the package without
ERROR: re-linking dependencies, risking various problems.
*** Error code 1