Subject: Help! apache22, mod_perl, apr, apr-util, ap2-auth-mysql (NetBSD 3.1, 2007Q2)
To: None <>
From: Paul Newhouse <>
List: pkgsrc-users
Date: 09/24/2007 09:10:51
Running NetBSD 3.1 using pkgsrc 2007Q2

: pkg_info |grep apache
apache-2.2.6        Apache HTTP (Web) server, version 2

: pkg_info |grep apr   
apr-util-1.2.8nb1   Apache Portable Runtime utilities
apr-  Apache Portable Runtime

>From 2007Q2/pkgsrc/www I run:

: (cd ap2-perl; make update 2>&1)  # and get

=> Required installed package apr-0.9.*: NOT found
=> Verifying update for ../../devel/apr0
===> Resuming update for apr-
===> Installing in devel/apr-util
=> Required installed package digest>=20010302: digest-20060826 found
===> Checking for vulnerabilities in apr-util-1.2.8nb1
===> Installing for apr-util-1.2.8nb1
ERROR: apr-util-1.2.8nb1 is already installed - perhaps an older version?
ERROR: If so, you may use either of:
ERROR:     - "pkg_delete apr-util-1.2.8nb1" and "/usr/bin/make reinstall"
ERROR:       to upgrade properly
ERROR:     - "/usr/bin/make update" to rebuild the package and all
ERROR:       of its dependencies
ERROR:     - "/usr/bin/make replace" to replace only the package without
ERROR:       re-linking dependencies, risking various problems.
*** Error code 1

Where did I go wrong?

Paul N.