Subject: my package issues with apache
To: None <>
From: Jeremy C. Reed <>
List: pkgsrc-users
Date: 09/07/2007 12:24:52
A few issues I had today:

1) I upgraded expat yesterday on production system -- nothing depended on 

This was on NetBSD 3.1:

 $ pkg_delete -V        

Today I restarted apache and it failed -- wrong libexpat.

 $ pkg_info -n apache 
 Information for apache-1.3.34nb1:


So I built new apache on my build system. I can't use apache from FTP 
because I have custom settings (using suexec).

2) So I installed it with "pkg_add -u" and it failed to start:

 $ /etc/rc.d/apache start
 Shared object "" not found
 /usr/pkg/sbin/apachectl start: httpd could not be started

I had libmm-1.3.1 (from Jun 28 2006) with:


So I installed the dependency from FTP 

$ pkg_add -u /home/reed/.pkg_get/libmm-1.4.2.tgz

And I was able to upgrade run apache.

pkgsrc/devel/libmm/ has:

BUILDLINK_API_DEPENDS.libmm+=   libmm>=1.2.1
BUILDLINK_ABI_DEPENDS.libmm+=   libmm>=1.2.2nb1

I looked at the pkgsrc libmm cvs log and I just updated this buildlink 

  Jeremy C. Reed