Subject: Re: pkgsrc on Solaris 10
To: =?ISO-8859-1?Q?Gerardo_Santana_G=F3mez_Garrido?= <>
From: Christopher Vance <>
List: pkgsrc-users
Date: 08/29/2007 09:53:02
On 8/29/07, Gerardo Santana G=F3mez Garrido <> wro=
> I just to thank you guys for pkgsrc.
> I'm a BSD user, maintaining a hand of Solaris boxes. I really missed
> the BSD way of doing things.
> I can tell you that pkgsrc-2007Q2 is working great on Solaris 10. For
> those that may be reading this now, or in the future, watch the
> following:
> * pkgsrc was installed from source. The bootstrap works fine.
> * Update your /usr/sfw/lib/
>    More about that here:
> * The GCC that comes in pkgsrc (2.95.3) didn't work for me. It has
> bugs (fixed in gcc 4, not 3) and after fixing them, it triggered some
> problems building db4. I'm using SUNWgcc (3.4.3) instead.
> Hope this can help someone and save him/her time.

I'm trialling pkgsrc current on Solaris 10 (SPARC).  Using gcc34 seems
to work for most of the things I've tried.  I bootstrapped using the
gcc we already had installed, but now pkgsrc is self-hosted, and the
bootstrap compiler and libraries are gone.

It seems bmake is misconfigured to use the wrong shell on Solaris, but
I've worked around that so far.

I still haven't worked out how to get teTeX to recognize that I have
libXpm installed and don't want or need xpm and the things it drags in
- but that's probably just a familiarization issue.