Subject: Re: libXrender broken also.[SEC = UNCLASSIFIED]
To: None <>
From: =?UTF-8?Q?C=C3=A9sar_Catri=C3=A1n_Carre=C3=B1o?= <>
List: pkgsrc-users
Date: 08/26/2007 21:30:55
Content-Type: text/plain; charset=UTF-8
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

On Mon, 27 Aug 2007 09:58:43 +1000
"Paul (NCC/CS.)" <> wrote:
> On Sun, 2007-08-26 at 11:42 -0400, C=C3=A9sar Catri=C3=A1n Carre=C3=B1o w=
> > On Sat, 25 Aug 2007 12:07:49 +1000
> > "Paul (NCC/CS.)" <> wrote:
> > >
> > > Can anyone help with this please?
> > > broken packages all over in latest pkgsrc!
> > > paul.
> >=20
> > I started yesterday a bulk build of all my packages, using pkg_comp,
> > now that I've set X11 modular. Are you building all your X11 packages
> > from the beginning?
> I don't have X11_TYPE set at all.
> I was just building it as a dependancy of evolution.

You was just building x11/libXrender as a dependancy for evolution, but
if you have X11_TYPE undefined, x11/Xrender is used instead. That
means, libXrender is not used when X11_TYPE is undefined. So there is
a layer 8 OSI error.

Besides, you seem to have two pkgsrc directories, you start compiling
at /usr/pkgsrc_CVS_250807 and the error code ends with /usr/pkgsrc . You
should start building all from /usr/pkgsrc .

Try just doing make at /usr/pkgsrc/mail/evolution, let it work and show
the commands you did and complete errors, avoiding the compiler output
and starting from a fresh pkgsrc.tar.gz from ftp so someone can help.

C=C3=A9sar Catri=C3=A1n Carre=C3=B1o

Content-Type: application/pgp-signature

Version: GnuPG v1.4.7 (NetBSD)