Subject: Re: skype is really stale
To: None <>
From: clayton <>
List: pkgsrc-users
Date: 08/21/2007 15:43:45
On Mon, 20 Aug 2007 15:29:59 +0200
Roland Illig <> wrote:

> clayton wrote:
> > Current version in pkgsrc is skype_staticQT-, which is
> > giving me some problems (crappy audio, can't access my USB
> > headphones) that I think the latest and greatest skype version
> > might do better with.
> > 
> > I tried a couple of simple Makefile hacks:
> > * changed skype_staticQT- to skype_staticQT-, which
> > found nothing to download.
> > * changed skype_staticQT- to skype-, which
> > downloaded skype- from skype, but had some fatal
> > errors on "make install".
> It would have been helpful to see the actual error messages. Even if 
> they are of no use for you, some others usually understand what's
> wrong and can help you.
> I've updated it. Please try if it works now.
> Roland

Hi Roland,

Thanks for the quick update. I am not seeing the errors I saw before and
we are onto a new problem now. The new skype installs OK, but when I try
to run it I get this:

{2} skype&
{3} ./skype: error while loading shared libraries:
cannot open shared object file: No such file or directory

There would appear to be a missing library, which shows up nicely in my
Debian partition but which a locate offers no sign of in either pkgsrc
or wip, ie.:

{6} locate libasound

On the Debian side:
$ apt-cache show libasound2
Description: ALSA library
 This package contains the ALSA library and its standard

I seem to recall that one of the major improvements in recent versions
of Skype is better ALSA support.

I don't suppose libasound is hidden in some already existing pkgsrc
library? Or I could sym link to the binary in the Debian partition? That
would be too easy, I am guessing..... (I tried the sym link idea in a
couple of places [/usr/lib and /usr/pkg/lib] but it didn't work.)