Subject: Re: modular-xorg trouble with wscons vtys
To: Alan Barrett <>
From: Sverre Froyen <>
List: pkgsrc-users
Date: 08/20/2007 09:53:37
On Monday 20 August 2007, you wrote:
> I run NetBSD-current/i386.  I recently switched to modular-xorg from
> whatever version of XFree86 is built from src/x11.  I now have several
> problems relating to the interaction between X and wscons vtys.
> A possibly-related problem is that switching between wscons virtual
> consoles is broken while X is running (but still works fine to switch
> between text consoles, provided you never use X at all).  I have seen
> several
> manifestations of what I suspect is a single underlying problem:

I see that too, but only with the latest xorg version.  See my (just posted) 
post to pkgsrc-users.

> * Sometimes, just after starting the X server, keyboard input just
> doesn't work at all, although the mouse works.  Pressing alt-control-F1
> usually makes the keyboard start working.  It's as if the X server
> decided to display itself on ttyE0 (instead of the ttyE4 that I would
> have preferred, since I have getty running on ttyE{0,1,2,3}), but failed
> to switch the keyboard focus to ttyE1, instead leaving it on whatever
> other tty was previously in use (usually ttyE1 in my tests).

I believe I saw this too, although in my case the mouse appeared dead as well.

> * Sometimes, when the X server dies or gets killed, the display switches
> to text mode as expected, but the keyboard is in a weird state, with
> keys sending what I assume are binary key codes, as if the mapping from
> keystrokes to characters has been disabled.  Before long, the system
> locks up completely, and needs to be power cycled.

I absolutely observed this.

> * I can get things to more or less work by logging in in a text console
> and running startx.  However, pressing alt-control-F{1,2,3,...} does not
> switch virtual consoles.

And this.