Subject: Re: xorg regression?
To: Sverre Froyen <>
From: Steven M. Bellovin <>
List: pkgsrc-users
Date: 08/20/2007 12:15:48
On Mon, 20 Aug 2007 09:44:45 -0600
Sverre Froyen <> wrote:

> Hi,
> On Saturday morning, I cvs update'ed my pkgsrc, deleted all packages
> and rebuilt the package subset that I normally use.  Running the new
> version of xorg, I see massive problems with keyboard input.  Both
> key down and key up event are frequently missed (input characters are
> missing and keys keep repeating until another key is pressed).  Also,
> the ctl-alt-esc and ctl-alt-fn combinations are ignored.  Mouse
> events appear normal.  I have also seen Xwindows hang a few times
> (some of hangs can be revocered by logging in over the network and
> killing the X server).  On further examination, it appears that the
> problems are only present when running a KDE component such as
> konquerer (I do not have to run the KDE desktop to see the problems).

What I'm seeing is *really* sluggish interactive behavior, and I don't
run KDE anything.  On an idle machine -- not a slow one; it's a 3.4Ghz
Dell with 1G of RAM -- I've seen repeated delayed character echoes in
xterm, for example.  I don't know if my problem is the kernel or xorg;
I'm seeing application slowness, too.  (I updated to -current as of
Wednesday Aug 15 and cc'd current-users.)

My Xorg environment is 

modular-xorg-apps-1.3 Modular Xorg application meta-package
modular-xorg-server- Xorg X11 Server from modular X11
modular-xorg-drivers-1.1 Modular Xorg driver meta-package
modular-xorg-fonts-1.0 Modular Xorg font meta-package

plus xterm-224.

		--Steve Bellovin,