Subject: compiling libXfont-1.3.0 fails for me with pkgsrc-HEAD as of yesterday
To: None <>
From: Bernd Limbach <>
List: pkgsrc-users
Date: 08/19/2007 20:02:13

while building packages for modular-xorg-driver I face the 
problem that I cannot compile x11/libXfont from 
libXfont-1.3.0.tar.* failing at the file ftenc.c.

It complains about undeclared variables (?) and complains in 
line 214 that a ")" is expected before "face" and stops.

This is out of my head.

I tried to locate some information via google, but only 
found a problem which was fixed middle of July with updating 
old libXfont-1.2.x to 1.3.0.

My NetBSD is a 4.99.24 and pkgsrc-HEAD from today approx. 
17:00 CEST.

What I did so far:
- tried to compile with yetserdays pkgsrc. Found this out,
- updated pkgsrc-HEAD, Failed.
- deleted distfiles/libXfont-1.3.0.tar.bz2
   and fetch newly. Failed.
- looked at source, but no clue (not a programmer).

I guess it is not related to pkgsrc directly, but wonder if 
somebody else experienced that also.

Is there someone around who may can provide some assistance?

If there's more information needed, please let me know.

Thanks, Bernd