Subject: Re: (b)make replace is borken
To: Greg Troxel <>
From: Mark E. Perkins <>
List: pkgsrc-users
Date: 08/09/2007 08:25:22
On 2007/08/09 08:04, Greg Troxel wrote:
> "Mark E. Perkins" <> writes:
> I did just commit some changes, but after you updated.  Certainly please
> update again so we're debugging head.  I did tons of make replaces last
> night (via pkg_rolling-replace) and it was fine.

I just updated and see no changes to any infrastructure files since I updated
a few hours ago.  Nevertheless, I tried again with the same result.

> I think you are hitting a bug that's been there for a few weeks.

I have had no problems until this morning.  Conjecture: changes to pkg_install
are the problem.  But that's only a guess based on the fact that it appears to
be the most fundamental infrastructure change since I updated yesterday
morning (i.e., I had no 'replace' issues yesterday).

> Basically my experience is:
> $ make replace
> will su/sudo to do part of the replace, but not do all the steps
> $ sudo make replace
> will work
> Is this how it is for you?

In a word, no :)  The pkg to be pkg_tarup'd is still not being passed down.

-> sudo bmake replace
=> Required installed package digest>=20010302: digest-20070803 found
===> Checking for vulnerabilities in p5-Devel-Symdump-2.0700
===> Replacing for p5-Devel-Symdump-2.0700
WARNING: experimental target - DATA LOSS MAY OCCUR.
Warning: no package matching p5-Devel-Symdump found
ERROR: No packages to tarup identified!
Usage: /usr/pkg/bin/pkg_tarup [-a] [-K pkg_dbdir] [-d pkgrepository] [-s
pkg_sufx] installed_pkg|pattern [...]
The following environment variables are used:
 (unless overriden by command line parameters)
 PKGREPOSITORY - A destination directory for packages (/tmp)
 PKG_DBDIR     - The location of the package database directory
 PKG_SUFX      - The suffix to append to the package (.tgz)
*** Error code 1

bmake: stopped in /usr/pkgsrc/devel/p5-Devel-Symdump
*** Error code 1

bmake: stopped in /usr/pkgsrc/devel/p5-Devel-Symdump
*** Error code 1

bmake: stopped in /usr/pkgsrc/devel/p5-Devel-Symdump