Subject: (b)make replace is borken
To: None <>
From: Mark E. Perkins <>
List: pkgsrc-users
Date: 08/09/2007 07:23:37
pkgsrc updated this morning....  Now I can't (b)make replace.


-> pwd
-> bmake replace
=> Required installed package digest>=20010302: digest-20070803 found
===> Checking for vulnerabilities in p5-Devel-Symdump-2.0700
===> Replacing for p5-Devel-Symdump-2.0700
WARNING: experimental target - DATA LOSS MAY OCCUR.
=> Becoming ``root'' to make su-replace (/usr/bin/sudo)
Warning: no package matching p5-Devel-Symdump found
ERROR: No packages to tarup identified!
Usage: /usr/pkg/bin/pkg_tarup [-a] [-K pkg_dbdir] [-d pkgrepository] [-s
pkg_sufx] installed_pkg|pattern [...]
The following environment variables are used:
 (unless overriden by command line parameters)
 PKGREPOSITORY - A destination directory for packages (/tmp)
 PKG_DBDIR     - The location of the package database directory
 PKG_SUFX      - The suffix to append to the package (.tgz)
*** Error code 1

bmake: stopped in /usr/pkgsrc/devel/p5-Devel-Symdump
*** Error code 1

bmake: stopped in /usr/pkgsrc/devel/p5-Devel-Symdump
*** Error code 1

bmake: stopped in /usr/pkgsrc/devel/p5-Devel-Symdump

-> pkg_info | egrep 'bmake-|tarup|_install|Symdump'
bmake-20051105nb3   Portable (autoconf) version of NetBSD 'make' utility
p5-Devel-Symdump-2.0604 Perl5 module for inspecting perl's symtable/class hiers
pkg_install-20070808 Package management and administration tools for pkgsrc
pkg_tarup-1.6.6     Generates binary package(s) from installed pkg(s)