Subject: Re: README.html: cannot find vulnerability list
To: None <>
From: David Lord <>
List: pkgsrc-users
Date: 08/06/2007 15:14:09
On 6 Aug 2007, at 13:02, Adrian Portelli wrote:

> David Lord wrote:
> ..
> > Here I find that audit-packages man page gives flags such as -V and 
> > more importantly -Q varname, but the audit-packages script itself 
> > both here and also as checked on doesn't include use 
> > of those flags. The -Q option is used in make readme scripts. I've 
> > emailed Adrian with debug output etc.
> > 
> > David
> ...
> Hi David,
> Just to clarify there are two versions of audit-packages.  Up until
> pkg_install-20070714 there was only the security/audit-packages package.
>  As of pkg_install-20070714 audit-packages was re-written and merged
> into the pkgtools/pkg_install package.  If you're running
> pkg_install>=20070714 you should not have security/audit-packages
> installed.  There was already a CONFLICTS line in pkgtools/pkg_install
> to prevent this and I've also recently added a mirrored line in
> security/audit-packages to prevent this from happening.

It doesn't prevent it but just makes it very difficult :-(. If the 
conficts message had mentioned the change to it now being part of 
pkg_install rather than just conficts with I'd not have forced 
install of security/audit-packages.

$ audit-packages -V

from 'uname -v' :- NetBSD 4.0_BETA2 .... Thu Jul 12 15:28

$ cd /usr/pkgsrc/www/links
$ make readme

Now works ok.