Subject: Getting started with modular xorg
To: None <>
From: Steven M. Bellovin <>
List: pkgsrc-users
Date: 08/04/2007 21:50:47
I'm trying to switch a machine from monolithic xorg to modular xorg.
It isn't working...

The machine in question is running 4.0beta2 from April.  It had had
monolithic xorg; it never had XFree86.  I built a large set of packages
on another 4.0beta2 machine, using pkg_comp.  I deleted *all* packages
from the target and added (among others) modular-xorg-apps, -server,
-fonts, and -drivers.  I build a new xorg.conf file; more accurately, I
ran 'X -configure' and accepted what it said, except that I added in
HorizSync and VertRefresh lines since for some reason xorg can't read
that from the monitor.  (Kubuntu can, albeit on a different machine via
a KVM switch.  I haven't tried booting that CD on this machine yet.)  

When I run 'startx', though, the X server starts chewing up 100% of the
CPU and the keyboard is completely dead.  I can't ctl+alt+backspace,
ctl+alt+Fn, etc.  If I 'kill -9' the X server, all is well; I just have
to switch back to screen 0 since it's on screen 5 (albeit in VGA mode).

I tried deleting my timing lines; that didn't help.  Monolithic xorg
liked those lines just fine, but ran -- in VGA mode -- without them.

Have I missed something?

		--Steve Bellovin,