Subject: Re: README.html: cannot find vulnerability list
To: None <>
From: David Lord <>
List: pkgsrc-users
Date: 08/02/2007 15:28:37
On 2 Aug 2007, at 0:34, Gary Thorpe wrote:

> Hi,
> Whenever I try to do 'make README.html' in a package directory, I
> encounter this problem (hand-copied):
> ...
> Flattening build dependencies
> ls: /pkg_vulnerabilities: No such file or directory
> No vulnerability file found (/pkg_vulnerabilities).
> The genereated README.html then has no vulnerability information. The
> vulnerability file is located in
> /usr/pkgsrc/distfiles/pkg_vulnerabilities. I have tried two different
> pakcages (www/links and www/firefox) with the same result.
> Any ideas on why it cannot find it (audit-packages placed the file
> there and seems to work with it fine)?

Doesn't work here either but never tried before and on old system it 
doesn't find it either as I have a separate PKGVULNDIR set but if 
left at default DISTDIR (/usr/pkgsrc_distfiles) it works ok. On 
updated pc (pkg_info -V = 20070715) there is a PVDIR in mkreadme and 
genreadme.awk but that seems to end up pointing to rootfs.