Subject: Re: xorg-server build fails on 4.0
To: Steven M. Bellovin <>
From: brad harder <>
List: pkgsrc-users
Date: 07/18/2007 20:28:08
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

On Wed, Jul 18, 2007 at 10:37:09PM -0400, Steven M. Bellovin wrote:
> I tried building xorg-server 6.9.0nb14 (as part of monolithic xorg)
> using pkg_comp on a 4.0 machine.  The 4.0 build sets are from July 2.

I got the same thing some time ago -- I think the culprit is the latest fre=

The ft_isdigit macro, specifically, is the problem.

I sent a note directly to (freetype2 maintainer), but haven't=
 got a resonponse, and I haven't sent a formal pr yet :P

What I did to temporarily fix the issue is adjust the reference to ft_isdig=
it -> isdigit in two places...

[I'll look and send another note...]

The other thing I experienced was that fonts wouldn't install, because one =
of the font handling utilities failed to build, and then the fonts weren't =
properly processed when I tried to install. For this reason, you'll need to=
 keep your eyes peeled for the second occurance. [checks logs, notes its "b=
dftopcf"]... You'll notice when you get:

/usr/pkg/xorg/bin/bdftopcf -t 6x9.bdf | gzip > 6x9.pcf.gz
sh: /usr/pkg/xorg/bin/bdftopcf: not found
/usr/pkg/xorg/bin/bdftopcf -t 6x10.bdf | gzip > 6x10.pcf.gz
sh: /usr/pkg/xorg/bin/bdftopcf: not found
/usr/pkg/xorg/bin/bdftopcf -t 6x12.bdf | gzip > 6x12.pcf.gz
sh: /usr/pkg/xorg/bin/bdftopcf: not found
/usr/pkg/xorg/bin/bdftopcf -t 6x13.bdf | gzip > 6x13.pcf.gz
sh: /usr/pkg/xorg/bin/bdftopcf: not found

Sorry for the lack of detail, but this was my general experience, fwiw.

I'll see what I can muster for details from my logs and a rebuild on my sys=

> The build failed:
> cc -o Xprt -O2 -fno-strict-aliasing -ansi -Dasm=3D__asm -Wall -Wpointer-a=
rith -Wstrict-prototypes                           -Wmissing-prototypes -Wm=
issing-declarations           =20
>          -Wredundant-decls -Wnested-externs -Wundef     -L/pkg_comp/obj/p=
kgsrc/x11/xorg-server/default/xc/exports/lib   Xprint/ddxInit.o Xprint/dpms=
stubs.o Xprint/miinitext.o  =20
>       os/libcwrapper.o dix/libdix.a os/libos.a  Xprint/libprinter.a      =
 Xprint/raster/libraster.a Xprint/pcl/libpcl.a Xprint/pcl-mono/libpcl.a Xpr=
int/ps/libps.a mfb/libmfb.a c
> fb/libcfb.a            cfb32/libcfb32.a mfb/libmfb.a dix/libxpstubs.a mi/=
libmi.a composite/libcomposite.a damageext/libdamage.a miext/damage/libdama=
ge.a xfixes/libxfixes.a miext
> /cw/libcw.a                   Xext/libexts.a xkb/libxkb.a os/libos.a Xi/l=
ibxinput.a                   lbx/liblbx.a                   /pkg_comp/obj/p=
> /xc/lib/lbxutil/liblbxutil.a  randr/librandr.a render/librender.a Xext/li=
bext.a dbe/libdbe.a record/librecord.a GL/glx/libglx.a                GL/me=
sa/GLcore/libGLcore.a XTrap/l
> ibxtrap.a -L/usr/pkg/xorg/lib    /pkg_comp/obj/pkgsrc/x11/xorg-server/def=
ault/xc/lib/font/libXfont.a -L/pkg_comp/obj/pkgsrc/x11/xorg-server/default/=
=2Ebuildlink/lib -Wl,-R /pkg_co
> mp/obj/pkgsrc/x11/xorg-server/default/.buildlink/lib -lfreetype dix/libxp=
stubs.a  -L/usr/lib -Wl,-R/usr/lib -lz -lm                  -lXau -lXdmcp -=
li386 -lX11 -L/usr/pkg/lib -L
> /usr/pkg/xorg/lib  -Wl,-R/usr/pkg/lib  -Wl,-R/usr/pkg/xorg/lib
> Xprint/ps/libps.a(psout_ftpstype1.o): In function `PsOut_DownloadFreeType=
> psout_ftpstype1.c:(.text+0x64): warning: warning: tempnam() possibly used=
 unsafely, use mkstemp() or mkdtemp()
> /pkg_comp/obj/pkgsrc/x11/xorg-server/default/xc/lib/font/libXfont.a(fttoo=
ls.o): In function `FTcheckForTTCName':
> fttools.c:(.text+0xc5): undefined reference to `ft_isdigit'
> *** Error code 1
> Stop.
> make: stopped in /pkg_comp/obj/pkgsrc/x11/xorg-server/default/xc/programs=
> *** Error code 1
> Stop.
> make: stopped in /usr/pkgsrc/x11/xorg-server
> *** Error code 1
> 		--Steve Bellovin,



Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: Digital signature
Content-Disposition: inline

Version: GnuPG v1.4.6 (GNU/Linux)