Subject: Re: Problems building gedit, gimp, etc
To: Jan Danielsson <>
From: Jeremy C. Reed <>
List: pkgsrc-users
Date: 05/12/2007 16:45:16
On Sat, 12 May 2007, Jan Danielsson wrote:

>    It simply seems, like Bernd Ernesti suggested, that build system is
> unable to determine that popt 1.10.7 > 1.5 when building libbonobo.
>    How are these problems solved in pkgsrc?

Patch the configure script to skip that check. Or use an environment 
variable (CONFIGURE_ENV) to tell configure to skip that check.

And then just use BUILDLINK_API_DEPENDS.popt to decide what is needed. (It 
is at  popt>=1.7nb3 currently.)

Or complain to upstream (libbonobo) to have them improve their configure 
script. (Maybe they have already fixed this?)

>    I've wondered how pkgsrc handles odd naming conventions, like the
> "converging against pi" latex? Or if someone would releases a "Yellow"
> version of a program, followed by a "Red" version?

  Jeremy C. Reed