Subject: Re: Problems building gedit, gimp, etc
To: Jeremy C. Reed <>
From: Jan Danielsson <>
List: pkgsrc-users
Date: 05/12/2007 23:20:34
This is an OpenPGP/MIME signed message (RFC 2440 and 3156)
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable

Jeremy C. Reed wrote:
>> checking for LIBBONOBO... yes
>> checking for SERVER... yes
>> checking for poptStrippedArgv in -lpopt... no
>> configure: error: You must have popt version 1.5 or greater installed.=

>> *** Error code 1
>> Stop.
>> make: stopped in /usr/pkgsrc/devel/libbonobo
> Can you have a look at the config.log maybe in=20
> devel/libbonobo/work/libbonobo-2*/config.log to see what the real probl=
> is? (Search in it for popt.)

   It simply seems, like Bernd Ernesti suggested, that build system is
unable to determine that popt 1.10.7 > 1.5 when building libbonobo.

   How are these problems solved in pkgsrc?

   I've wondered how pkgsrc handles odd naming conventions, like the
"converging against pi" latex? Or if someone would releases a "Yellow"
version of a program, followed by a "Red" version?

Kind regards,
Jan Danielsson

Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: OpenPGP digital signature
Content-Disposition: attachment; filename="signature.asc"

Version: GnuPG v1.4.7 (NetBSD)