Subject: lang/sun-jdk15
To: None <>
From: Ernesto Bascon <>
List: pkgsrc-users
Date: 04/23/2007 20:32:26

I was trying to install Sun JDK 1.5 into my NetBSD 3.1 AMD64 box with pkgsrc.
pkgsrc asked me to download the JDK/JRE AMD64/i386 binaries from the
Java site; I added the binaries to /usr/pkgsrc/distfiles and after
doing that, an error saying to me that my platform is not supported.

1. What that error was shown after asking me for download binary
files? is it a bug? I think pkgsrc should show me the error
immediately after my first "make install" on my environment.

2. The error message says to me that I need to have NetBSD 3.9 or
later before trying to install JDK 1.5 on my platform. Is there
something internal that prevents to me of using JDK 1.5 on my system?

3. Is there a secure way of patching my makefiles to force the
installation on my system?

Thanks in advance