Subject: Re: Opera 9.2, emul/linux32 and amd64 (was: Can't run opera on amd64)
To: Juan RP <juan@xtrarom.org>
From: Loic Hoguin <essen@dev-extend.eu>
List: pkgsrc-users
Date: 04/16/2007 03:39:20
On Mon, 16 Apr 2007 02:53:42 +0200, Juan RP <juan@xtrarom.org> wrote:

> On Mon, 16 Apr 2007 01:56:14 +0200
> "Loic Hoguin" <essen@dev-extend.eu> wrote:
>
>> Hello,
>>
>> It seems that the fixes for compat/linux32 select timeouts
>> have been committed. Opera now works pretty well on amd64,
>> I have been playing with it for some time without problems.
>>
>> I haven't seen however a fix for the installation under
>> amd64. To be able to run Opera you must have the 32bit suse
>> compat packages installed, which is not currently possible
>> (Nicolas Joly was working on it earlier). Also it seems that
>> the Opera Makefile must be fixed, as it installs the files
>> in emul/linux instead of emul/linux32.
>
> Bah... that was pretty easy :-)
>
> http://www.netbsd.org/~xtraeme/linux32.diff
>
> Apply the patch in pkgsrc and put "USE_COMPAT_LINUX32=yes" in  
> /etc/mk.conf.
> Install opera... enjoy (I'm just using Opera on my amd64 :-).
>
> I'll try to convert more packages (firefox, nspluginwrapper, etc).

Hmm but what if I need to have linux 32bit emulation (for opera)
AND linux 64bit emulation? USE_COMPAT_LINUX32 won't let me install
both.

I think the best solution is to have separate packages for the
suse ones, but based on the same base. Also, the current ones are
installing suse-32bit if you are running i386, and suse-64bit
if running amd64. Wouldn't it be best to have the current suse
packages install only suse-32bit, and to add new packages for
suse-64bit?

Regards,

-- 
Loc Hoguin
Dev:Extend