Subject: problem including fonts...
To: None <>
From: George Georgalis <>
List: pkgsrc-users
Date: 03/22/2007 16:47:36
Problem getting fonts in a pdf file...

        cd /usr/pkgsrc/graphics/graphviz/ && make install
        cd /usr/pkgsrc/fonts/ms-ttf && echo 'ACCEPTABLE_LICENSES+=ms-ttf-license' >>/etc/mk.conf && make install
        mkfontscale /usr/pkg/lib/X11/fonts/TTF
        mkfontdir /usr/pkg/lib/X11/fonts/TTF
        cd /usr/pkgsrc/fonts/fontconfig && make install
        fc-cache -v

the last four lines there are per the ms-ttf/MESSAGE file
to get the fonts setup (ignored instructions to configure
/etc/X11/XF86Config since I use xorg but don't have a server
running), when I run the following (verbose), I get indication the
fonts are used, but in the pdf I get badly formatted courier font.

dot -v -Tps2 graphic/ | ps2pdf - graphic/design-net-min.pdf

The plugin configuration file:
                was successfully loaded.
    render      :  canon cmap cmapx dia dot fig gd gd2 gif hpgl imap ismap jpeg jpg mif mp pcl pic plain plain-ext png ps ps2 svg svgz vrml vtx wbmp xdot
    layout      :  circo dot fdp neato twopi
    textlayout  : 
    device      : 
    usershape   :  png-gd
dot: fontname=Verdana fontpath=/usr/pkg/lib/X11/fonts/TTF/Verdana.ttf
network simplex: 22 nodes 23 edges 0 iter 0.00 sec
mincross: pass 0 iter 0 trying 0 cur_cross 0 best_cross 0
mincross _anonymous_0: 0 crossings, 0.00 secs.
network simplex: 53 nodes 69 edges 6 iter 0.00 sec
routesplines: 24 edges, 76 boxes 0.00 sec

when I write the ps file out, I can open it and the specified
Verdana font is used.  After running ps2pdf, Verdana is mentioned
in the pdf source but not rendered in the doc.

I tried ps2pdf13 and ps2pdf12.  Seems there is a problem with
ps2pdf, any suggestions?

// George

George Georgalis, systems architect, administrator <IXOYE><