Subject: Firefox2 from pkgsrc on OpenBSD
To: None <>
From: The masked-coder known as Randux <>
List: pkgsrc-users
Date: 03/15/2007 17:44:53
Subject: Re: How to use on OpenBSD? (has Perl-5.8.8 in OBSD base)
Date: Wed, 14 Mar 2007 10:44:45 +0300

> The masked-coder known as Randux wrote:
> > ... and now firefox2 and sylpheed-claws (my main reasons for using pkgsrc on OpenBSD) have just crashed. 
> Are you saying that firefox2 crashed? You either got rid of perl
> dependency or managed to build lang/perl. How you did this?
> Last time I tried to build perl, it failed on
> LD_LIBRARY_PATH=/path/to/libperl/in/WRKSRCDIR ./miniperl
> OpenBSD couldn't find
> I resolved this problem but then I got DynaLoader failure at a later
> stage.
> -- 
> Alexander Nasonov

Greetings, Alexander, and sorry for my late reply, I've been travelling on business. I also apologise to the group as I see there are quite a few emails on the topic that I must respond to, so if I write something out of order it's because I'm working my way backwards through the queue.

No, I couldn't get on with the FF build but Perl and most of the tools (autoconf, etc) all built properly.  I've decided to abandon using pkgsrc  on OpenBSD for now. Whilst on NetBSD it seems to work really nicely indeed, there are too many issues for me running it on OpenBSD. I'll try to build things by hand as much as possible. I'm not sure what to do about Firefox2, but I can live with 1.5 until a packkge becomes available.