Subject: Re: "make update" as non-root
To: None <>
From: OBATA Akio <>
List: pkgsrc-users
Date: 02/09/2007 11:03:57

On Thu, 8 Feb 2007 21:52:58 +0100, Lieven De Keyzer wrote:
> When I try to update a package as a regular user, I get following output:
> $ bmake update
> ===> Deinstalling for SDL_sound-1.0.1nb6
> => Becoming ``root'' to make su-deinstall (/bin/su)
> Password:
> Running /usr/pkg/sbin/pkg_delete -K /var/db/pkg  SDL_sound-1.0.1nb5
> pkg_delete: package `SDL_sound-1.0.1nb5' is required by other packages:
>         dosbox-0.65nb3

I have also seen this error message since some month ago, but didn't inspection.

Yes, it should be fixed in mk/ r1.1906.

"Of course I love NetBSD":-)
OBATA Akio /