Subject: Re: Xfce: both 4.2.4 and 4.4.0 or just 4.4.0?
To: Martti Kuparinen <>
From: Geert Hendrickx <>
List: pkgsrc-users
Date: 01/22/2007 09:50:25
On Mon, Jan 22, 2007 at 09:45:42AM +0200, Martti Kuparinen wrote:
> Hi,
> A small poll about Xfce releases in pkgsrc...
> Do you want to have and/or use:
> 1) I want to have both 4.2.x and 4.4.0 versions so I can pick the older version
> in case of horrible problems with 4.4.0
> 2) having just 4.4.0 is fine for me

I'm not an xfce user but this is a general package maintainer's problem.
If you think xfce 4.2.x will not continue to be supported upstream, just
upgrade the existing packages to xfce 4.4.0.  pkgsrc-2006Q4 still has the
stable 4.2.x version for a while, and I suppose any serious problems with
the new version will be fixed in 4.4.whatever at the time pkgsrc-2007Q1 is

Only if older versions are still being maintained upstream (as is the case
with for example postgresql, apache, ...), it makes sense to maintain these
versions in pkgsrc (IMO).