Subject: Re: xfce4 broken after the latest updates
To: None <>
From: Simon Truss <>
List: pkgsrc-users
Date: 01/20/2007 14:56:44
Joerg Sonnenberger wrote:
> On Fri, Jan 19, 2007 at 07:20:38PM +0000, Simon Truss wrote:
>> I had this the other day. The cause is /usr/X11R6/lib/libfontconfig is 
>> being used instead of pkg/lib version. I patched the link in X11R6/lib 
>> and it all works fine. You should see an error about missing fonts when 
>> the window manager starts.
> What does "make show-var VARNAME=USE_BUILTIN.fontconfig" in the
> directory of the failing package or its toolkit give?

pkgcomp2006Q4.conf# cd /usr/pkgsrc/meta-pkgs/xfce4
pkgcomp2006Q4.conf# make show-var VARNAME=USE_BUILTIN.fontconfig

It is quite likely that I caused my own problems. The same day, I 
updated my userland (netbsd-4 cvs), and could have clobbered things 
then. Later when I upgraded my packages and started X would have been 
the first I noticed.