Subject: Re: libxslt upgrade, please
To: None <>
From: Christian Biere <>
List: pkgsrc-users
Date: 01/20/2007 15:31:59
Blair Sadewitz wrote:
> Thanks for updating this package. I was wondering, however, whether or not
> you think this needs -fno-strict-aliasing. I added it when I switched the
> package to the newer version myself, but only because the compiler warned
> repeatedly of breaking strict aliasing rules.

If there are such warnings, the flag should certainly be used. Even if
there are no warnings, the flag might still be required because the
compiler cannot detect all violations. It's best to use this flag for
now and report it upstream so that it's fixed appropriately since the
use of this flag prevents some optimizations.