Subject: Re: emacs internal conflict?
To: None <>
From: George Georgalis <>
List: pkgsrc-users
Date: 01/18/2007 03:23:16
On Thu, Jan 18, 2007 at 07:48:11AM +0100, Antoine Reilles wrote:
>On Wed, Jan 17, 2007 at 11:30:32PM -0500, George Georgalis wrote:
>> ===> Installing for emacs-21.4anb7
>> ERROR: emacs-21.4anb7 conflicts with installed package(s):
>> ERROR:     emacs-nox11-21.4anb6
>> ERROR: They install the same files into the same place.
>> ERROR: Please remove conflicts first with pkg_delete(1).
>> *** Error code 1
>You have to install either emacs or emacs-nox, because they are
>I quess you see pkgsrc trying to install emacs instead of using the
>emacs-nox you previously installed. To make sure pkgsrc uses emacs-nox
>as dependancy for all emacs related packages, you have to put in your
>/etc/mk.conf the following line:
>That way, installing, e.g. auxtex will not fail, auctex requiring

thanks. tried it like this...

cd /usr/pkgsrc/editors/emacs-nox11 && printf 'EMACSVERSION=21.4\nEMACS_TYPE=emacs21nox\n' >>/etc/mk.conf && make install

turns out that "math/ess" is asking for emacs-21.4anb7 over the
installed emacs-nox11-21.4anb6 but I can't figure out what to tell
it to use nox11.

// George

George Georgalis, systems architect, administrator <IXOYE><