Subject: how to handle xgettext --language=perl ?
To: None <>
From: Jeremy C. Reed <>
List: pkgsrc-users
Date: 01/01/2007 21:51:29
On NetBSD -current:

$    xgettext --language=perl 
xgettext: no input file given
Try `xgettext --help' for more information.

On NetBSD 3.0.1:

>    xgettext --language=perl 
language `perl' unknown

What is the correct way to handle this with pkgsrc?

My error on 3.0.1 is:

 xgettext ... -Lperl
 language `perl' unknown

The package I am working on (updated ikiwiki) is using:

DEPENDS+=       p5-Locale-libintl-[0-9]*:../../misc/p5-Locale-libintl
DEPENDS+=       p5-gettext-[0-9]*:../../devel/p5-gettext
USE_TOOLS+=	xgettext

Should I force this ikiwiki to use gettext-tools? What is the correct way?